summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript
diff options
context:
space:
mode:
authorJesse Zhang <sen.zhang@windriver.com>2013-01-06 09:56:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-08 14:50:37 +0000
commit981bd3a297ff51f30bebfa189e1516c7507cf278 (patch)
tree0b35ccded5af498f9f56d24ea2685a1570553587 /meta/recipes-extended/ghostscript/ghostscript
parent858646c7bd11d1dad8c14e30f3fe6b4bd58a31b2 (diff)
downloadopenembedded-core-contrib-981bd3a297ff51f30bebfa189e1516c7507cf278.tar.gz
ghostscript: fix endianness detection
[ CQID: WIND00394747 ] The original patch removes endianness detection completely, causing lcms to be built against the wrong endian. Instead, pass the correct endian through the recipe using SITEINFO_ENDIANNESS. (From OE-Core rev: 0a07ec7d13becc7ce87c502e75a006300a7090a5) Signed-off-by: Jesse Zhang <sen.zhang@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.05-NOT-check-endian.patch40
1 files changed, 9 insertions, 31 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.05-NOT-check-endian.patch b/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.05-NOT-check-endian.patch
index ab4326f3c5..c79063f7c1 100644
--- a/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.05-NOT-check-endian.patch
+++ b/meta/recipes-extended/ghostscript/ghostscript/ghostscript-9.05-NOT-check-endian.patch
@@ -4,15 +4,14 @@ So remove the check for Yocto.
Upstream-Status: Pending
Signed-off-by: Kang Kai <kai.kang@windriver.com>
+Signed-off-by: Sen Zhang <sen.zhang@windriver.com>
---- ghostscript-9.05/base/configure.ac.orig 2012-03-14 15:28:30.828956872 +0800
-+++ ghostscript-9.05/base/configure.ac 2012-03-14 15:29:05.060957357 +0800
-@@ -1739,25 +1739,25 @@
- dnl check for big/little endian for LCMS
- dnl --------------------------------------------------
+--- ghostscript-9.05/base/configure.ac.orig 2013-01-06 10:02:08.699479511 +0800
++++ ghostscript-9.05/base/configure.ac 2013-01-06 10:01:52.275382106 +0800
+@@ -1741,13 +1741,13 @@
+
+ AC_MSG_CHECKING([for big endian])
--AC_MSG_CHECKING([for big endian])
--
-AC_RUN_IFELSE(
- [AC_LANG_PROGRAM([#include <stdio.h>], [
- static const int one = 1;
@@ -20,18 +19,6 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
- ])],
- [LCMS_BIGENDIAN=1],
- [LCMS_BIGENDIAN=0])
--
--if test "x$LCMS_BIGENDIAN" != "x0"; then
-- LCMS_ENDIAN="-DUSE_BIG_ENDIAN=$LCMS_BIGENDIAN"
-- LCMS2_ENDIAN="-DCMS_USE_BIG_ENDIAN=$LCMS_BIGENDIAN"
-- AC_MSG_RESULT(yes)
--else
-- LCMS_ENDIAN=
-- LCMS2_ENDIAN=
-- AC_MSG_RESULT(no)
--fi
-+dnl AC_MSG_CHECKING([for big endian])
-+dnl
+dnl AC_RUN_IFELSE(
+dnl [AC_LANG_PROGRAM([#include <stdio.h>], [
+dnl static const int one = 1;
@@ -39,16 +26,7 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
+dnl ])],
+dnl [LCMS_BIGENDIAN=1],
+dnl [LCMS_BIGENDIAN=0])
-+dnl
-+dnl if test "x$LCMS_BIGENDIAN" != "x0"; then
-+dnl LCMS_ENDIAN="-DUSE_BIG_ENDIAN=$LCMS_BIGENDIAN"
-+dnl LCMS2_ENDIAN="-DCMS_USE_BIG_ENDIAN=$LCMS_BIGENDIAN"
-+dnl AC_MSG_RESULT(yes)
-+dnl else
-+dnl LCMS_ENDIAN=
-+dnl LCMS2_ENDIAN=
-+dnl AC_MSG_RESULT(no)
-+dnl fi
-
- AC_SUBST(LCMS_ENDIAN)
+ if test "x$LCMS_BIGENDIAN" != "x0"; then
+ LCMS_ENDIAN="-DUSE_BIG_ENDIAN=$LCMS_BIGENDIAN"
+