summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-05-04 12:07:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:17:39 +0100
commit013e837f96ea9d9daf53c497a965a021e686ba37 (patch)
tree09435491cb044167cd4827443c78556582ff07dc /meta/recipes-extended/gawk
parentaddd517f17c4595fe03d9d5f0ad1d7daf86a3f39 (diff)
downloadopenembedded-core-contrib-013e837f96ea9d9daf53c497a965a021e686ba37.tar.gz
gawk-3.1.5: fix build with automake 1.12
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-extended/gawk')
-rw-r--r--meta/recipes-extended/gawk/gawk-3.1.5/gawk_fix_for_automake-1.12.patch41
-rw-r--r--meta/recipes-extended/gawk/gawk_3.1.5.bb2
2 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk-3.1.5/gawk_fix_for_automake-1.12.patch b/meta/recipes-extended/gawk/gawk-3.1.5/gawk_fix_for_automake-1.12.patch
new file mode 100644
index 0000000000..b3e7987cef
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk-3.1.5/gawk_fix_for_automake-1.12.patch
@@ -0,0 +1,41 @@
+Upstream-Status: Pending
+
+automake 1.12 has depricated automatic de-ANSI-fication support
+
+this patch avoids these kinds of errors:
+
+| configure.ac:127: error: automatic de-ANSI-fication support has been removed
+| /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/aclocal-1.12/protos.m4:12: AM_C_PROTOTYPES is expanded from...
+| configure.ac:127: the top level
+| autom4te: m4 failed with exit status: 1
+...
+| Makefile.am:27: error: automatic de-ANSI-fication support has been removed
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/04
+
+Index: gawk-3.1.5/configure.ac
+===================================================================
+--- gawk-3.1.5.orig/configure.ac
++++ gawk-3.1.5/configure.ac
+@@ -124,7 +124,6 @@ fi
+
+ dnl check for C compiler for automake
+ AM_PROG_CC_STDC
+-AM_C_PROTOTYPES
+
+ dnl Cygwin doesn't like to get libs with full paths
+ dnl since that overrides linking against DLLs.
+Index: gawk-3.1.5/Makefile.am
+===================================================================
+--- gawk-3.1.5.orig/Makefile.am
++++ gawk-3.1.5/Makefile.am
+@@ -24,7 +24,7 @@
+ ## process this file with automake to produce Makefile.in
+
+ # Automatic de-ANSI-fication if needed, make .bz2 files also.
+-AUTOMAKE_OPTIONS = ansi2knr dist-bzip2
++AUTOMAKE_OPTIONS = dist-bzip2
+
+ # This undocumented variable insures that aclocal runs
+ # correctly after changing configure.ac
diff --git a/meta/recipes-extended/gawk/gawk_3.1.5.bb b/meta/recipes-extended/gawk/gawk_3.1.5.bb
index d5d9beaa49..4c7cdf36b1 100644
--- a/meta/recipes-extended/gawk/gawk_3.1.5.bb
+++ b/meta/recipes-extended/gawk/gawk_3.1.5.bb
@@ -34,6 +34,8 @@ ALTERNATIVE_PATH = "gawk"
ALTERNATIVE_LINK = "${bindir}/awk"
ALTERNATIVE_PRIORITY = "100"
+CFLAGS += "-D PROTOTYPES"
+
do_install_append() {
# remove the link since we don't package it
rm ${D}${bindir}/awk