summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-07 18:06:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-08 16:01:36 +0100
commit8392d60e05c4eed0b08273c1a934eeea54215079 (patch)
treef7abc1352fd0a546ae40acd4bf3265f29c080a1c /meta/recipes-extended/gawk
parentb9630048451342a0ca1080955b0df35b0c94ce46 (diff)
downloadopenembedded-core-contrib-8392d60e05c4eed0b08273c1a934eeea54215079.tar.gz
gawk: ptest fixes
In minimal images all tests pass due to a missing dependency on make. Add the missing dependecy. The test list created by the run-ptest script is incorrect as it includes entries like "fi". Simplify it and correct it. Some tests are skipped due to mpfr not being enabled. Correctly mark these as SKIP. Some tests need the "../gawk" script, create a link to it so the tests work correctly. Also print more information in the failed test cases. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/gawk')
-rw-r--r--meta/recipes-extended/gawk/gawk/run-ptest24
-rw-r--r--meta/recipes-extended/gawk/gawk_5.0.0.bb3
2 files changed, 21 insertions, 6 deletions
diff --git a/meta/recipes-extended/gawk/gawk/run-ptest b/meta/recipes-extended/gawk/gawk/run-ptest
index d23f0bf6d7..f67a95874f 100644
--- a/meta/recipes-extended/gawk/gawk/run-ptest
+++ b/meta/recipes-extended/gawk/gawk/run-ptest
@@ -1,10 +1,22 @@
#!/bin/sh
cd test
-for i in `grep -vE "@|^$|#|Gt-dummy" Maketests |awk -F: '{print $1}'`; \
- do LC_ALL=${GAWKLOCALE:-C} LANG=${GAWKLOCALE:-C} srcdir=`pwd` AWK=gawk CMP=cmp \
- make -f Maketests $i >$i.tmp 2>&1; \
- grep -q "Error" $i.tmp; \
- if [ $? -eq 0 ]; then echo "FAIL: $i"; \
- else echo "PASS: $i"; rm -f $i.tmp; fi; \
+for i in `grep -E "^[a-z0-9_-]*:$" Maketests |awk -F: '{print $1}'`; do
+ #LC_ALL=${GAWKLOCALE:-C} LANG=${GAWKLOCALE:-C}
+ srcdir=`pwd` AWKPROG=gawk AWK=gawk CMP=cmp make -f Maketests $i >$i.tmp 2>&1
+ if [ -e _$i ]; then
+ cat _$i
+ grep -q "support not compiled in" _$i
+ if [ $? -eq 0 ]; then
+ echo "SKIP: $i"
+ continue
+ fi
+ fi
+ grep -q "Error" $i.tmp
+ if [ $? -eq 0 ]; then
+ echo "FAIL: $i"
+ else
+ echo "PASS: $i"
+ rm -f $i.tmp
+ fi
done
diff --git a/meta/recipes-extended/gawk/gawk_5.0.0.bb b/meta/recipes-extended/gawk/gawk_5.0.0.bb
index b1e1b212a3..578901355c 100644
--- a/meta/recipes-extended/gawk/gawk_5.0.0.bb
+++ b/meta/recipes-extended/gawk/gawk_5.0.0.bb
@@ -40,6 +40,7 @@ inherit ptest
do_install_ptest() {
mkdir ${D}${PTEST_PATH}/test
+ ln -s ${bindir}/gawk ${D}${PTEST_PATH}/gawk
for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \
do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
done
@@ -47,4 +48,6 @@ do_install_ptest() {
-e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
}
+RDEPENDS_${PN}-ptest += "make"
+
BBCLASSEXTEND = "native nativesdk"