aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_3.16.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@lge.com>2014-11-13 10:22:19 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-20 14:06:30 +0000
commitbedcf3cf03d0c6283e06949a0c98773390c01ed0 (patch)
treef07fe6e5060038743af9c3c647854cbcec99a0bb /meta/recipes-extended/ethtool/ethtool_3.16.bb
parent5faae24198ded58c5328e9f3e5ab99c89047a57d (diff)
downloadopenembedded-core-contrib-bedcf3cf03d0c6283e06949a0c98773390c01ed0.tar.gz
ethtool: Upgrade to 3.16
Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_3.16.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.16.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_3.16.bb b/meta/recipes-extended/ethtool/ethtool_3.16.bb
new file mode 100644
index 0000000000..92a0704800
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_3.16.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ file://ethtool-uint.patch \
+ "
+
+SRC_URI[md5sum] = "3806bae34c153e2b9e2859e85c54788d"
+SRC_URI[sha256sum] = "a6f1433824af7b390ed4e66dfc7cee047d6d1f56dbb8ceef9fe905d63aef5275"
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}