aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_3.15.bb
diff options
context:
space:
mode:
authorRoxana Ciobanu <roxana.ciobanu@intel.com>2014-08-27 18:22:26 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-28 15:11:10 +0100
commitb983f74fe5147d09f1743eaff4c7808d0411c742 (patch)
tree17ec655728d885b5503910c0fe21dff0c8fbfbba /meta/recipes-extended/ethtool/ethtool_3.15.bb
parent4c13eced019eac49f047a620994c1b56af5d4951 (diff)
downloadopenembedded-core-contrib-b983f74fe5147d09f1743eaff4c7808d0411c742.tar.gz
ethtool: upgrade to 3.15
Signed-off-by: Roxana Ciobanu <roxana.ciobanu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_3.15.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.15.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_3.15.bb b/meta/recipes-extended/ethtool/ethtool_3.15.bb
new file mode 100644
index 0000000000..8cd10dfb43
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_3.15.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Display or change ethernet card settings"
+DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
+HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+ file://run-ptest \
+ file://avoid_parallel_tests.patch \
+ file://ethtool-uint.patch \
+ "
+
+SRC_URI[md5sum] = "7e94dd958bcd639aad2e5a752e108b24"
+SRC_URI[sha256sum] = "562e3cc675cf5b1ac655cd060f032943a2502d4d59e5f278f02aae92562ba261"
+
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+ oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+ cp ${B}/Makefile ${D}${PTEST_PATH}
+ install ${B}/test-cmdline ${D}${PTEST_PATH}
+ install ${B}/test-features ${D}${PTEST_PATH}
+ install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+}