aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2012-12-28 22:19:25 -0700
committerSaul Wold <sgw@linux.intel.com>2013-01-04 22:12:05 -0800
commit0e6f76d9d5929f8c23916827dccc8389419f0163 (patch)
tree0a4b93f79946674e743e1b46a6a71e405a870fee /meta/recipes-extended/chkconfig
parent1f9d979ca60eca2277f53f24dc59f9ab18e81195 (diff)
downloadopenembedded-core-contrib-0e6f76d9d5929f8c23916827dccc8389419f0163.tar.gz
chkconfig: don't inherit autotools
This buildsystem is not autoconf/automake, but make. While we're at it, also make the install not hardcode the path to /usr/share/locale. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/chkconfig')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
index fd7bd1a111..7915594c6e 100644
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
@@ -12,23 +12,29 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
DEPENDS = "libnewt popt"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
SRC_URI[md5sum] = "c2039ca67f2749fe0c06ef7c6f8ee246"
SRC_URI[sha256sum] = "18b497d25b2cada955c72810e45fcad8280d105f17cf45e2970f18271211de68"
-inherit autotools gettext
+inherit gettext
-# Makefile uses RPM_OPT_fLAGS to construct CFLAGS
+# Makefile uses RPM_OPT_FLAGS to construct CFLAGS
#
-EXTRA_OEMAKE += 'RPM_OPT_FLAGS="${CFLAGS}" MANDIR="${mandir}" \
- BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
-
-do_install_append() {
- mkdir -p ${D}${sysconfdir}/chkconfig.d
- rm -f ${D}${sbindir}/update-alternatives
+EXTRA_OEMAKE = "\
+ 'RPM_OPT_FLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+ 'BINDIR=${base_sbindir}' \
+ 'SBINDIR=${sbindir}' \
+ 'MANDIR=${mandir}' \
+"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' install
+ mkdir -p ${D}${sysconfdir}/chkconfig.d
+ rm -f ${D}${sbindir}/update-alternatives
}
do_install_append_linuxstdbase() {