aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2011-08-10 16:57:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-11 19:13:38 +0100
commitf3a52a73251b26ead15abd4910dc82c1011ab852 (patch)
tree3b753e5a21067aa980be6c868a751782800978b6 /meta/recipes-extended/chkconfig
parent62269642ce0e0e56d68d495b6c4d27327c9ed649 (diff)
downloadopenembedded-core-contrib-f3a52a73251b26ead15abd4910dc82c1011ab852.tar.gz
chkconfig: remove link for update-alternatives to disambiguate
[YOCTO #936] "update-alternatives" installed: one in /usr/sbin from chkconfig \ (symlinked to "alternatives"), and the other in /usr/bin \ from update-alternatives-cworth. It appears for whatever reason that the one from chkconfig is run \ during postinst processing but if you run the script from the command \ line it gets the other one. this is due to differences in the PATH environment variable. The following is the sequence to call scripts after kernel booting inittab -->rcS -->./S40networking(PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin) -->S98configure(call rpm-postinstall) #"/usr/sbin" is found prior to "/usr/bin", so update-alternatives from chkconfig is run in this script -->rc5.d -->profile(profile:4:PATH="/usr/local/bin:/usr/bin:/bin" profile:15: PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin) #"/usr/bin/" is found prior to "/usr/sbin", so update-alternatives from update-alternatives-cworth is run in this script So I remove the symlink (update-alternatives linked to chkconfig). The one from update-alternatives-cworth is left alone. Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Diffstat (limited to 'meta/recipes-extended/chkconfig')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.52.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.52.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.52.bb
index 659f964313..6dc8a0e131 100644
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.52.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.52.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
DEPENDS = "libnewt popt"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
@@ -23,4 +23,5 @@ inherit autotools gettext
do_install_append() {
mkdir -p ${D}/etc/chkconfig.d
+ rm -f ${D}/usr/sbin/update-alternatives
}