aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2012-10-10 15:16:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 12:03:25 +0100
commitecdb24c21b7b90b83748cbe5891437b2183321d7 (patch)
treeb8e83c5f7ca38ecec271704ece14a64b319e9ed3 /meta/recipes-extended/chkconfig
parent2129b793bc7875d929a91e22be72108d4d15e081 (diff)
downloadopenembedded-core-contrib-ecdb24c21b7b90b83748cbe5891437b2183321d7.tar.gz
chkconfig: pass CFLAGS to Makefile
The environment CFLAGS is not used by the chkconfig Makefile, so debug and optimization options are ignored. So, we use RPM_OPT_FLAGS to pass CFLAGS into Makefile. Upstream-Status: Inappropriate [configuration] Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/chkconfig')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
index 9e0e1a05f0..0f6398f57e 100644
--- a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
DEPENDS = "libnewt popt"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
@@ -21,7 +21,10 @@ SRC_URI[sha256sum] = "18b497d25b2cada955c72810e45fcad8280d105f17cf45e2970f182712
inherit autotools gettext
-EXTRA_OEMAKE += 'MANDIR="${mandir}" BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
+# Makefile uses RPM_OPT_fLAGS to construct CFLAGS
+#
+EXTRA_OEMAKE += 'RPM_OPT_FLAGS="${CFLAGS}" MANDIR="${mandir}" \
+ BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
do_install_append() {
mkdir -p ${D}${sysconfdir}/chkconfig.d