aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-03-03 10:24:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-03 23:13:33 +0000
commit994cb5be07270b8414d46e01ed7888e2de448589 (patch)
tree92453894a82af86315772d2f7c38eb9ba4cbf3e4 /meta/recipes-extended/chkconfig
parent794da1a4cffaedc8a9ceeb0b089d7236b22e7913 (diff)
downloadopenembedded-core-contrib-994cb5be07270b8414d46e01ed7888e2de448589.tar.gz
recipe: add chkconfig for LSB command test
chkconfig is a system tool for maintaining the /etc/rc*.d hierarchy, and LSB command test will check 2 links point to command chkconfig Signed-off-by: Kang Kai <kai.kang@windriver.com>
Diffstat (limited to 'meta/recipes-extended/chkconfig')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.49.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.49.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.49.bb
new file mode 100644
index 0000000000..bbaba7144b
--- /dev/null
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.49.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy"
+
+DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \
+information for system services. Chkconfig manipulates the numerous \
+symbolic links in /etc/rc.d, to relieve system administrators of some \
+of the drudgery of manually editing the symbolic links."
+
+HOMEPAGE = "http://fedorahosted.org/releases/c/h/chkconfig"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
+
+DEPENDS = "libnewt gettext popt"
+
+PR = "r0"
+
+SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${P}.tar.bz2"
+SRC_URI[md5sum] = "9b5e91d25f4f3b21f4c0bdf55a721431"
+SRC_URI[sha256sum] = "775100a9d6f70fbd8f33ed24b560b6842161fc496c21b1fc6d2aed646f9d855f"
+
+inherit autotools
+
+do_install_append() {
+# mkdir -p ${D}/etc/rc.d/init.d
+# mkdir -p ${D}/etc/rc.d/rc{0,1,2,3,4,5,6}.d
+ mkdir -p ${D}/etc/chkconfig.d
+}