aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-11-03 15:06:24 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-10 21:09:22 +0800
commita0fb0c209056a958a5d775cc9efee57875a6234a (patch)
tree12adf55b69370d9f3d71ddf1f0f331cf027c90bd /meta/recipes-extended/bzip2/bzip2_1.0.6.bb
parent12a861359a3413ded52174c814e8653c56caee17 (diff)
downloadopenembedded-core-contrib-a0fb0c209056a958a5d775cc9efee57875a6234a.tar.gz
bzip2: upgrade to version 1.0.6
resolves security bug CVE-2010-0405 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.6.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
new file mode 100644
index 0000000000..1e858f4b11
--- /dev/null
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Very high-quality data compression program."
+HOMEPAGE = "http://www.bzip.org/"
+SECTION = "console/utils"
+LICENSE = "bzip2"
+LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2"
+PR = "r3"
+
+SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
+ file://configure.ac \
+ file://Makefile.am"
+
+CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_LINKS = "${bindir}/bunzip2 ${bindir}/bzcat"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/configure.ac ${S}/
+ cp ${WORKDIR}/Makefile.am ${S}/
+ cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
+}
+
+PROVIDES_append_virtclass-native = " bzip2-full-native"
+BBCLASSEXTEND = "native"