summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-05 22:26:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-06 10:30:16 +0100
commit1ae11a6ea5ff82f6492a880ff45e19f3779918da (patch)
treefbb444cc04ea7153781260536106ffe8a993c231 /meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
parentb5304ce438666a7418746f4ddd32703ae3188089 (diff)
downloadopenembedded-core-contrib-1ae11a6ea5ff82f6492a880ff45e19f3779918da.tar.gz
bzip2: set correct soname
The correct name for the bzip2 shared library is libbz2.so.1.0.6, not libbz2.so.0.0.0. Pass -version-info to libtool to correct this. Also fix the configure.ac so that is doesn't mention libXrender and has the right version. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am')
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
index 1d163b6c98..05d389fc7d 100644
--- a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
@@ -1,5 +1,6 @@
lib_LTLIBRARIES = libbz2.la
+libbz2_la_LDFLAGS = -version-info 1:6:0
libbz2_la_SOURCES = blocksort.c \
huffman.c \