aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2011-01-26 19:37:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:12 +0000
commitce9d6ebf34d7972021529c6270426c1760b967e5 (patch)
tree54b6417d219bd79eadc0719809405615645d4c8e /meta/recipes-extended/bash
parentabc25cb88570bf54d3bb518b5083402894cca061 (diff)
downloadopenembedded-core-contrib-ce9d6ebf34d7972021529c6270426c1760b967e5.tar.gz
bash: use /bin/bash as default shell when bash is included
though bash is included in LSB profile, it doesn't use update-alternative to take effect and thus it's still busybox behaving as /bin/sh. Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash.inc5
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb2
-rw-r--r--meta/recipes-extended/bash/bash_4.1.bb2
3 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index aa8cac8222..a87b87ff4b 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -17,6 +17,11 @@ sbindir = "/sbin"
EXTRA_OECONF = "--enable-job-control"
export CC_FOR_BUILD = "${BUILD_CC}"
+ALTERNATIVE_NAME = "sh"
+ALTERNATIVE_PATH = "${base_bindir}/bash"
+ALTERNATIVE_LINK = "${base_bindir}/sh"
+ALTERNATIVE_PRIORITY = "100"
+
do_configure () {
gnu-configize
oe_runconf
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index ee563d626a..e5a3e3643d 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
DEPENDS = "ncurses"
-PR = "r6"
+PR = "r7"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
diff --git a/meta/recipes-extended/bash/bash_4.1.bb b/meta/recipes-extended/bash/bash_4.1.bb
index 6a558ed2cd..cea40420cb 100644
--- a/meta/recipes-extended/bash/bash_4.1.bb
+++ b/meta/recipes-extended/bash/bash_4.1.bb
@@ -1,6 +1,6 @@
require bash.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
http://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-001;apply=yes;striplevel=0;name=patch001 \