aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-24 09:45:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:44:57 +0100
commita0d2cde52459d8cd3f222486e71ddaa3d3041a61 (patch)
treee2d0c53ae681abe8fc0f7c21fb4429e274e9e76b /meta/recipes-extended/bash
parentf8c32f74020df2af21257d790c00c874a3fb2052 (diff)
downloadopenembedded-core-contrib-a0d2cde52459d8cd3f222486e71ddaa3d3041a61.tar.gz
bash ptest: Sed away the Makefile dependency to remove error messages.
The bash Makefile defines a dependency on itself and tries to run configure, causing error messages when running ptest on target: make: *** No rule to make target `configure.in', needed by `configure'. make: *** No rule to make target `aclocal.m4', needed by `configure'. make: *** No rule to make target `config.h.in', needed by `configure'. make: *** No rule to make target `Makefile.in', needed by `Makefile'. make: Failed to remake makefile `Makefile'. This patch edits out this dependency in the Makefile installed for ptest, to get rid of these messages. (From OE-Core rev: b5fe8c9ff330105337b003be0de2f970545d13ef) Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash-4.2/run-ptest2
-rw-r--r--meta/recipes-extended/bash/bash.inc1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/bash/bash-4.2/run-ptest b/meta/recipes-extended/bash/bash-4.2/run-ptest
index 66f1eee543..8dd3b9981d 100644
--- a/meta/recipes-extended/bash/bash-4.2/run-ptest
+++ b/meta/recipes-extended/bash/bash-4.2/run-ptest
@@ -1,2 +1,2 @@
#!/bin/sh
-echo Makefile: | make -f Makefile -f - -k THIS_SH=/bin/bash BUILD_DIR=. runtest
+make -k THIS_SH=/bin/bash BUILD_DIR=. runtest
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index c619f824e9..2f4519cdda 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -40,6 +40,7 @@ do_install_append () {
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
}
pkg_postinst_${PN} () {