aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-03-06 10:41:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-07 11:14:39 +0000
commit00b771415282f5bcbae105ee556b2bf76416bda3 (patch)
tree580af15d032300d261496f2394637b72d698f383 /meta/recipes-extended/bash
parent6819d000cbb3c997513956373fac2bc15ddd1926 (diff)
downloadopenembedded-core-contrib-00b771415282f5bcbae105ee556b2bf76416bda3.tar.gz
bash: Use new _ptest functions
(From OE-Core rev: 1839f969bc5d6e1555f5e5d218c0265f817fe300) Signed-off-by: Björn Stenberg <bjst@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash')
-rw-r--r--meta/recipes-extended/bash/bash.inc15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index 20a23f030f..c619f824e9 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -25,10 +25,8 @@ do_configure_prepend () {
fi
}
-do_compile_append () {
- if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
- oe_runmake buildtest
- fi
+do_compile_ptest () {
+ oe_runmake buildtest
}
do_install_append () {
@@ -37,12 +35,11 @@ do_install_append () {
mkdir -p ${D}${base_bindir}
mv ${D}${bindir}/bash ${D}${base_bindir}
fi
+}
- if [ "${PN}" = "${BPN}" -a ${PTEST_ENABLED} = "1" ]; then
- ptest_do_install
- make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
- cp ${B}/Makefile ${D}${PTEST_PATH}
- fi
+do_install_ptest () {
+ make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
+ cp ${B}/Makefile ${D}${PTEST_PATH}
}
pkg_postinst_${PN} () {