aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_4.3.30.bb
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-04-19 04:55:53 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-29 07:53:57 +0100
commit5f82f3df7d4a7d6ae9a1ea3b6bc1d620a3d6c329 (patch)
tree07596e4c0d3414afa0dc4f71ffd681485b2cd77b /meta/recipes-extended/bash/bash_4.3.30.bb
parent396353c3127b20244c4c5cc321adad7d4e48f544 (diff)
downloadopenembedded-core-contrib-5f82f3df7d4a7d6ae9a1ea3b6bc1d620a3d6c329.tar.gz
bash: fixed ptest run-builtins failed
1. redirect the stderr output of the command exec with -l option to /dev/null. Because when we run command exec with -l option in builtins.tests, it is a login shell, so it would read the file /etc/profile, that file executes the /usr/bin/resize which added by commit: cc6360f4c4d97e0000f9d3545f381224ee99ce7d The /usr/bin/resize is produced by busybox that source code resize.c contains: fprintf(stderr, ESC"7" ESC"[r" ESC"[999;999H" ESC"[6n"); In the end, it outputs an escape sequence to the stderr, so when we compare the test output file /tmp/xx with builtins.right, it failed. we need to redirect the stderr output to the /dev/null to solve the problem. 2. ensure the target system contains the locales "en_US.UTF-8". Because when run the run-builtins, it executes the source5.sub file that contain: LC_ALL=en_US.UTF-8 such as add the following to the local.conf: IMAGE_LINGUAS_append = " en-us" Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/bash/bash_4.3.30.bb')
-rw-r--r--meta/recipes-extended/bash/bash_4.3.30.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_4.3.30.bb b/meta/recipes-extended/bash/bash_4.3.30.bb
index 4426cf00a0..95ed3925c7 100644
--- a/meta/recipes-extended/bash/bash_4.3.30.bb
+++ b/meta/recipes-extended/bash/bash_4.3.30.bb
@@ -20,6 +20,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
file://test-output.patch \
file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \
file://run-ptest \
+ file://fix-run-builtins.patch \
"
SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447"