aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-04 19:45:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:39:34 +0000
commit5a10a6f153744922a5f0cab0ea98427a1d67ad6c (patch)
tree9156ce227b7147962ce495d2500593210dffccbc /meta/recipes-extended/at
parent78e05984b1ac48b1f25547ccd9740611cd5890a9 (diff)
downloadopenembedded-core-contrib-5a10a6f153744922a5f0cab0ea98427a1d67ad6c.tar.gz
at: modify sources in do_patch
Instead of copying the forked source files into ${S} in do_compile_prepend(), do it in a do_patch() postfunc. This ensures that the source archiver sees the changes for compliance and legal verification. (From OE-Core rev: 7d76d7d90f8e832ddaaebfae125c7f9aecfcac9f) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/at')
-rw-r--r--meta/recipes-extended/at/at_3.1.16.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/at/at_3.1.16.bb b/meta/recipes-extended/at/at_3.1.16.bb
index 0512bcb836..b11b587fcf 100644
--- a/meta/recipes-extended/at/at_3.1.16.bb
+++ b/meta/recipes-extended/at/at_3.1.16.bb
@@ -47,10 +47,10 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE_${PN} = "atd.service"
-
-do_compile_prepend () {
+copy_sources() {
cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
+do_patch[postfuncs] += "copy_sources"
do_install () {
oe_runmake -e "IROOT=${D}" install