aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpitests_20140828.bb
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-01-10 15:55:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 15:11:22 -0800
commit020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11 (patch)
tree05e437dd481d5665ad6663f49ab5e56c3713a764 /meta/recipes-extended/acpica/acpitests_20140828.bb
parent1264d26fa251ac11a9069f3e602dec6be9d8b9ba (diff)
downloadopenembedded-core-contrib-020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11.tar.gz
acpica: move from meta-oe to OE-core
qemu support for UEFI in OE-core depends on OVMF, which needs the iasl tools provided by this recipe. There's also an iasl recipe in meta-luv, but than can and will be replaced by this one, thus reducing overall maintenance work. Copied from meta-openembedded rev fa65be9ba (current master). Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Diffstat (limited to 'meta/recipes-extended/acpica/acpitests_20140828.bb')
-rw-r--r--meta/recipes-extended/acpica/acpitests_20140828.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpitests_20140828.bb b/meta/recipes-extended/acpica/acpitests_20140828.bb
new file mode 100644
index 0000000000..1f6f190c2e
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpitests_20140828.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Test suite used to validate ACPICA"
+HOMEPAGE = "http://www.acpica.org/"
+
+LICENSE = "Intel"
+LIC_FILES_CHKSUM = "file://tests/aapits/atexec.c;beginline=1;endline=115;md5=e92bcdfcd01d117d1bda3e814bb2030a"
+
+DEPENDS = "bison flex"
+
+SRC_URI = "https://acpica.org/sites/acpica/files/acpitests-unix-${PV}.tar.gz;name=acpitests \
+ https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz;name=acpica \
+ file://aapits-linux.patch \
+ file://aapits-makefile.patch \
+"
+SRC_URI[acpitests.md5sum] = "db9d6fdaa8e3eb101d700ee5ba4938ed"
+SRC_URI[acpitests.sha256sum] = "e576c74bf1bf1c9f7348bf9419e05c8acfece7105abcdc052e66670c7af2cf00"
+SRC_URI[acpica.md5sum] = "6f05f0d10166a1b1ff6107f3d1cdf1e5"
+SRC_URI[acpica.sha256sum] = "01d8867656c5ba41dec307c4383ce676196ad4281ac2c9dec9f5be5fac6d888e"
+
+S = "${WORKDIR}/acpitests-unix-${PV}"
+
+EXTRA_OEMAKE = "'CC=${TARGET_PREFIX}gcc ${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS}' 'OPT_CFLAGS=-Wall'"
+
+# The Makefiles expect a specific layout
+do_compile() {
+ cp -af ${WORKDIR}/acpica-unix2-${PV}/source ${S}
+ cd tests/aapits
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m0755 tests/aapits/bin/aapits ${D}${bindir}
+}
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"