aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-07-20 20:47:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-21 10:47:33 +0100
commite56064bad8a4e8626e7ff4096874fb7f36eb6880 (patch)
tree9b95a7ea144e5e41041d4138f10d011ada4b47ff /meta/recipes-devtools
parent5486cac29db6e67051fff7637a0abc9aeab661e5 (diff)
downloadopenembedded-core-contrib-e56064bad8a4e8626e7ff4096874fb7f36eb6880.tar.gz
python: save Makefile.sysroot in do_compile
* otherwise calling do_install twice results in Makefile.sysroot == Makefile.orig and distutils using wrong LIBDIR (from host) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
index 800ba04142..76f32f2481 100644
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -1,7 +1,7 @@
require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "${INC_PR}.8"
+PR = "${INC_PR}.9"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
@@ -54,6 +54,9 @@ do_compile() {
sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile
sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile
install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
+ # save copy of it now, because if we do it in do_install and
+ # then call do_install twice we get Makefile.orig == Makefile.sysroot
+ install -m 0644 Makefile Makefile.sysroot
oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
@@ -75,7 +78,6 @@ do_compile() {
do_install() {
# make install needs the original Makefile, or otherwise the inclues would
# go to ${D}${STAGING...}/...
- install -m 0644 Makefile Makefile.sysroot
install -m 0644 Makefile.orig Makefile
oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
@@ -86,7 +88,6 @@ do_install() {
DESTDIR=${D} LIBDIR=${libdir} install
install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
- rm Makefile.sysroot
if [ -e ${WORKDIR}/sitecustomize.py ]; then
install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}