aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-07-16 10:00:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:24:56 +0100
commitd76ede1e696d52c08ede8b6e539cb0895ee73b2f (patch)
treed54f70828005496b978e127e22f0ad48cd76bd78 /meta/recipes-devtools
parent99e1b18de5de1fb8558222cef2fc9aac27a797a6 (diff)
downloadopenembedded-core-contrib-d76ede1e696d52c08ede8b6e539cb0895ee73b2f.tar.gz
perl: revise the RRECOMMENDS_perl-modules for multilib case
current RRECOMMENDS_perl-modules replace the hardcode "perl-dbg", "perl-misc" etc. which does not work in multilib case. Instead, it should replace the "lib64-perl-dbg", "lib-64-perl-misc". without doing this, current code will produce RRECOMMENDS=lib64-lib64-xxx etc This patch revise the code to fix this issue Signed-off-by: Yu Ke <ke.yu@intel.com> Signed-off-by: Xu Dongxiao <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index c75a5322df..4b6b5a796b 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -282,7 +282,7 @@ FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
# packages (actually the non modules packages and not created too)
ALLOW_EMPTY_perl-modules = "1"
PACKAGES_append = " perl-modules "
-RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('perl-modules ', '').replace('perl-dbg ', '').replace('perl-misc ', '').replace('perl-dev ', '').replace('perl-pod ', '').replace('perl-doc ', '')}"
+RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('${PN}-modules ', '').replace('${PN}-dbg ', '').replace('${PN}-misc ', '').replace('${PN}-dev ', '').replace('${PN}-pod ', '').replace('${PN}-doc ', '')}"
python populate_packages_prepend () {
libdir = bb.data.expand('${libdir}/perl/${PV}', d)