aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-15 11:49:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-20 15:24:59 +0100
commit9673d7aa1f9e1c88ba69047b2e22636c755edaaa (patch)
tree575540f3d651bbf459b5cbf08eab7d19a9a8b969 /meta/recipes-devtools
parent6473c9096bf4995c21147e737322d800219c89ab (diff)
downloadopenembedded-core-contrib-9673d7aa1f9e1c88ba69047b2e22636c755edaaa.tar.gz
help2man-native: Add 1.38.2
This is a 'side port' of current oe.dev versions. PR is kept in sync but we drop out the target recipes in order to punt on potential perl problems. Here we do re-configure as we don't have a dance with perl-native to deal with. Now that we can build it, don't require it. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.38.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.38.2.bb b/meta/recipes-devtools/help2man/help2man-native_1.38.2.bb
new file mode 100644
index 0000000000..bea7fe9b1f
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.38.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Program to create simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+DEPENDS = "autoconf-native automake-native"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "426671c6fe79e5ef2233303367eab5a6"
+SRC_URI[sha256sum] = "952c29561bce8b233aa10af7f0e0c79c8243712810bf8ddf01e6efd82ce250d1"
+
+inherit autotools native
+
+EXTRA_OECONF = "--disable-nls"
+
+# We don't want to reconfigure things as it would require 'perlnative' to be
+# used.
+do_configure() {
+ oe_runconf
+}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}