aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-18 16:54:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-10 13:23:45 +0100
commit5f985f02a932ebce238a6b1c644d2e3179226aab (patch)
treecf6a8012ca427f9eb3d431058c84cfcf658ea9e9 /meta/recipes-devtools
parenta702a5efdaece4197ceefec2a3b4c1e872e82f11 (diff)
downloadopenembedded-core-contrib-5f985f02a932ebce238a6b1c644d2e3179226aab.tar.gz
cmake: put cmake.m4 and toolchain file in PN
Previously cmake-dev held some files which should be in cmake. - cmake.m4 should be in installed in cmake so it can be used out of the box - nativesdk-specific OEToolchainConfig.cmake file used to be in cmake, but the change of default packaging rules move it into cmake-dev. This recipe is the exception and it should be moved back. Add the extra paths to cmake, and clear FILES for cmake-dev to ensure nothing else slips in. (From OE-Core rev: a6ce79b87d3db57033a3d1710cb3292366a0a8f7) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.10.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_3.10.3.bb b/meta/recipes-devtools/cmake/cmake_3.10.3.bb
index 3f8fd7a997..7d81edc604 100644
--- a/meta/recipes-devtools/cmake/cmake_3.10.3.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.10.3.bb
@@ -44,7 +44,8 @@ do_install_append_class-nativesdk() {
FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}"
-FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}"
+FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION} ${datadir}/cmake ${datadir}/aclocal"
FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}"
+FILES_${PN}-dev = ""
BBCLASSEXTEND = "nativesdk"