aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-05-01 13:00:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-01 23:17:50 +0100
commite6fb2f9afe2ba6b676c46d1eb297ca9cc532d405 (patch)
tree5282f0201ed86aa3aab4273233082b3f8ea7a48b /meta/recipes-devtools
parentce1f3fd20d81545d6d5dfc68f86f9fddf8ac9bbf (diff)
downloadopenembedded-core-contrib-e6fb2f9afe2ba6b676c46d1eb297ca9cc532d405.tar.gz
Add texinfo.bbclass; recipes that use texinfo utils at build-time inherit it.
The class itself currently does nothing. The idea is to mark all recipes that make use of the texinfo utilities. In the future, this class could be used to suppress the generation/formatting of documentation for performance, explicitly track dependencies on these utilities, and eliminate Yocto's current dependency on the host system's texinfo utilities. Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf.inc2
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.2.bb2
-rw-r--r--meta/recipes-devtools/automake/automake.inc2
-rw-r--r--meta/recipes-devtools/binutils/binutils.inc2
-rw-r--r--meta/recipes-devtools/bison/bison_2.3.bb2
-rw-r--r--meta/recipes-devtools/bison/bison_2.7.1.bb2
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs.inc2
-rw-r--r--meta/recipes-devtools/flex/flex.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-common.inc2
-rw-r--r--meta/recipes-devtools/gdb/gdb-common.inc2
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.9.bb2
-rw-r--r--meta/recipes-devtools/libtool/libtool-2.4.2.inc2
-rw-r--r--meta/recipes-devtools/m4/m4.inc2
-rw-r--r--meta/recipes-devtools/make/make.inc2
-rw-r--r--meta/recipes-devtools/mtools/mtools_3.9.9.bb2
-rw-r--r--meta/recipes-devtools/mtools/mtools_4.0.18.bb2
16 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf.inc b/meta/recipes-devtools/autoconf/autoconf.inc
index 222106a78e..8ed4b134ea 100644
--- a/meta/recipes-devtools/autoconf/autoconf.inc
+++ b/meta/recipes-devtools/autoconf/autoconf.inc
@@ -29,7 +29,7 @@ RDEPENDS_${PN}_class-native = "m4-native gnu-config-native"
SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.gz \
file://program_prefix.patch"
-inherit autotools
+inherit autotools texinfo
do_configure() {
oe_runconf
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
index 98bdb59792..92e7099f20 100644
--- a/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.2.bb
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "cc2702dec21ba5b01144865163f6d1a54268d2b72aafc5520ad0e0cb57
DEPENDS = "guile-native libtool-native libxml2-native"
-inherit autotools native
+inherit autotools texinfo native
# autogen-native links against libguile which may have been relocated with sstate
# these environment variables ensure there isn't a relocation issue
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index b73cdeb60b..a1debd8d53 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -7,7 +7,7 @@ SECTION = "devel"
SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.gz"
-inherit autotools
+inherit autotools texinfo
do_configure() {
oe_runconf
diff --git a/meta/recipes-devtools/binutils/binutils.inc b/meta/recipes-devtools/binutils/binutils.inc
index 5ab2b92f14..afb582ad67 100644
--- a/meta/recipes-devtools/binutils/binutils.inc
+++ b/meta/recipes-devtools/binutils/binutils.inc
@@ -13,7 +13,7 @@ LICENSE = "GPLv3"
DEPENDS = "flex-native bison-native zlib-native gnu-config-native autoconf-native"
-inherit autotools gettext multilib_header
+inherit autotools gettext multilib_header texinfo
FILES_${PN} = " \
${bindir}/${TARGET_PREFIX}* \
diff --git a/meta/recipes-devtools/bison/bison_2.3.bb b/meta/recipes-devtools/bison/bison_2.3.bb
index a135451162..174916bcb1 100644
--- a/meta/recipes-devtools/bison/bison_2.3.bb
+++ b/meta/recipes-devtools/bison/bison_2.3.bb
@@ -22,7 +22,7 @@ SRC_URI[sha256sum] = "52f78aa4761a74ceb7fdf770f3554dd84308c3b93c4255e3a5c17558ec
DEPENDS_class-native = "gettext-native"
SRC_URI_class-native = "${BASE_SRC_URI}"
-inherit autotools gettext
+inherit autotools gettext texinfo
acpaths = "-I ${S}/m4"
do_configure_prepend () {
diff --git a/meta/recipes-devtools/bison/bison_2.7.1.bb b/meta/recipes-devtools/bison/bison_2.7.1.bb
index 1df750a255..4a3ad154db 100644
--- a/meta/recipes-devtools/bison/bison_2.7.1.bb
+++ b/meta/recipes-devtools/bison/bison_2.7.1.bb
@@ -28,7 +28,7 @@ LDFLAGS_prepend_libc-uclibc = " -lrt "
DEPENDS_class-native = "gettext-minimal-native"
SRC_URI_class-native = "${BASE_SRC_URI}"
-inherit autotools gettext
+inherit autotools gettext texinfo
acpaths = "-I ${S}/m4"
do_install_append_class-native() {
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs.inc b/meta/recipes-devtools/e2fsprogs/e2fsprogs.inc
index 99447c1540..bcd9ba7590 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs.inc
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs.inc
@@ -22,4 +22,4 @@ DEPENDS = "util-linux"
SRC_URI = "${SOURCEFORGE_MIRROR}/e2fsprogs/e2fsprogs-${PV}.tar.gz \
file://mkdir.patch"
-inherit autotools gettext pkgconfig multilib_header
+inherit autotools gettext texinfo pkgconfig multilib_header
diff --git a/meta/recipes-devtools/flex/flex.inc b/meta/recipes-devtools/flex/flex.inc
index 75c10ef340..54e4ec3b25 100644
--- a/meta/recipes-devtools/flex/flex.inc
+++ b/meta/recipes-devtools/flex/flex.inc
@@ -10,7 +10,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \
file://run-ptest \
"
-inherit autotools gettext ptest
+inherit autotools gettext texinfo ptest
M4 = "${bindir}/m4"
diff --git a/meta/recipes-devtools/gcc/gcc-common.inc b/meta/recipes-devtools/gcc/gcc-common.inc
index e56e598b75..0d19575b5a 100644
--- a/meta/recipes-devtools/gcc/gcc-common.inc
+++ b/meta/recipes-devtools/gcc/gcc-common.inc
@@ -5,7 +5,7 @@ LICENSE = "GPL"
NATIVEDEPS = ""
-inherit autotools gettext
+inherit autotools gettext texinfo
BPN = "gcc"
diff --git a/meta/recipes-devtools/gdb/gdb-common.inc b/meta/recipes-devtools/gdb/gdb-common.inc
index 60f03e734e..b4d48809d3 100644
--- a/meta/recipes-devtools/gdb/gdb-common.inc
+++ b/meta/recipes-devtools/gdb/gdb-common.inc
@@ -19,7 +19,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674 \
file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6"
-inherit autotools
+inherit autotools texinfo
SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
"
diff --git a/meta/recipes-devtools/guile/guile_2.0.9.bb b/meta/recipes-devtools/guile/guile_2.0.9.bb
index 60318e73cf..b35d54e7d2 100644
--- a/meta/recipes-devtools/guile/guile_2.0.9.bb
+++ b/meta/recipes-devtools/guile/guile_2.0.9.bb
@@ -29,7 +29,7 @@ SRC_URI[md5sum] = "a69b575d4a633bdd9118f3a4a1e97766"
SRC_URI[sha256sum] = "f70a38c8d9751f442679bfe61852bba8545af4d4355d037630997c2f37f2895b"
-inherit autotools gettext
+inherit autotools gettext texinfo
BBCLASSEXTEND = "native"
DEPENDS = "libunistring bdwgc gmp libtool libffi"
diff --git a/meta/recipes-devtools/libtool/libtool-2.4.2.inc b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
index d26982dc62..9c50d46fe2 100644
--- a/meta/recipes-devtools/libtool/libtool-2.4.2.inc
+++ b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
@@ -33,7 +33,7 @@ do_compile_prepend () {
./config.status
}
-inherit autotools
+inherit autotools texinfo
EXTRA_AUTORECONF = "--exclude=libtoolize"
DEPENDS = "libtool-native"
diff --git a/meta/recipes-devtools/m4/m4.inc b/meta/recipes-devtools/m4/m4.inc
index ae101c2b6d..4a83929f0c 100644
--- a/meta/recipes-devtools/m4/m4.inc
+++ b/meta/recipes-devtools/m4/m4.inc
@@ -3,7 +3,7 @@ DESCRIPTION = "GNU m4 is an implementation of the traditional Unix macro process
compatible although it has some extensions (for example, handling more than 9 positional parameters to macros). \
GNU M4 also has built-in functions for including files, running shell commands, doing arithmetic, etc."
-inherit autotools
+inherit autotools texinfo
EXTRA_OEMAKE += "'infodir=${infodir}'"
LDFLAGS_prepend_libc-uclibc = " -lrt "
diff --git a/meta/recipes-devtools/make/make.inc b/meta/recipes-devtools/make/make.inc
index 4036345089..57ea605b97 100644
--- a/meta/recipes-devtools/make/make.inc
+++ b/meta/recipes-devtools/make/make.inc
@@ -7,4 +7,4 @@ SECTION = "devel"
SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.bz2"
-inherit autotools gettext pkgconfig
+inherit autotools gettext pkgconfig texinfo
diff --git a/meta/recipes-devtools/mtools/mtools_3.9.9.bb b/meta/recipes-devtools/mtools/mtools_3.9.9.bb
index 38f09decd2..d995c8f042 100644
--- a/meta/recipes-devtools/mtools/mtools_3.9.9.bb
+++ b/meta/recipes-devtools/mtools/mtools_3.9.9.bb
@@ -38,7 +38,7 @@ SRC_URI[sha256sum] = "af083a73425d664d4607ef6c6564fd9319a0e47ee7c105259a45356cb8
S = "${WORKDIR}/mtools-${PV}"
-inherit autotools
+inherit autotools texinfo
EXTRA_OECONF = "--without-x"
diff --git a/meta/recipes-devtools/mtools/mtools_4.0.18.bb b/meta/recipes-devtools/mtools/mtools_4.0.18.bb
index 0cc7f6c6e2..6c71f0ab1f 100644
--- a/meta/recipes-devtools/mtools/mtools_4.0.18.bb
+++ b/meta/recipes-devtools/mtools/mtools_4.0.18.bb
@@ -31,7 +31,7 @@ SRC_URI = "${GNU_MIRROR}/mtools/mtools-${PV}.tar.bz2 \
file://no-x11.gplv3.patch"
-inherit autotools
+inherit autotools texinfo
EXTRA_OECONF = "--without-x"