aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-07-12 13:19:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:09:29 +0100
commit99e50d9e53ab23fc643c46378fa8c36190995335 (patch)
treee68259bb2ffabfe0d0e64f89aa2228fdd1fd8ed4 /meta/recipes-devtools
parenta88f1b5d88dbc5fb28be24b9787d73b9e0cdf183 (diff)
downloadopenembedded-core-contrib-99e50d9e53ab23fc643c46378fa8c36190995335.tar.gz
file: fix regression for determining DB file type
The version 5.33 introduced a regression bug for determining the DB file type. Backport a patch from upstream to fix it. Before apply the patch: $ file aliases.db aliases.db: created: Thu Jan 1 00:38:24 1970, modified: Thu Jan 1 00:00:00 1970 After apply the patch: $ file aliases.db aliases.db: Berkeley DB (Btree, version 9, native byte-order) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/file/file/fix-bogus-magic.patch32
-rw-r--r--meta/recipes-devtools/file/file_5.33.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file/fix-bogus-magic.patch b/meta/recipes-devtools/file/file/fix-bogus-magic.patch
new file mode 100644
index 0000000000..9a33ea7a0d
--- /dev/null
+++ b/meta/recipes-devtools/file/file/fix-bogus-magic.patch
@@ -0,0 +1,32 @@
+From c637aaad6f0db5ad45a5296c837cb1f5253d3e3a Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Thu, 24 May 2018 18:54:40 +0000
+Subject: [PATCH] fix bogus magic
+
+Upstream-Status: Backport
+[https://github.com/file/file/commit/4fb6a59df80d4974f8230bfce36e38e6de7d574f]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ magic/Magdir/dbpf | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/magic/Magdir/dbpf b/magic/Magdir/dbpf
+index 65cab61e..e81c5538 100644
+--- a/magic/Magdir/dbpf
++++ b/magic/Magdir/dbpf
+@@ -9,9 +9,7 @@
+ >4 ulelong x \b, version: %u.
+ >>8 ulelong x \b%u
+ >>>36 ulelong x \b, files: %u
++>>24 ledate !0 \b, created: %s
++>>28 ledate !0 \b, modified: %s
+ !:ext dbpf/package/dat/sc4
+ !:mime application/x-maxis-dbpf
+-4 ulelong 1
+->8 ulelong !1
+->>24 ledate !0 \b, created: %s
+->>>28 ledate !0 \b, modified: %s
+--
+2.13.3
+
diff --git a/meta/recipes-devtools/file/file_5.33.bb b/meta/recipes-devtools/file/file_5.33.bb
index 745ef10951..a29402a0ab 100644
--- a/meta/recipes-devtools/file/file_5.33.bb
+++ b/meta/recipes-devtools/file/file_5.33.bb
@@ -17,6 +17,7 @@ UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
SRC_URI = "git://github.com/file/file.git \
file://debian-742262.patch \
file://CVE-2018-10360.patch \
+ file://fix-bogus-magic.patch \
"
SRCREV = "219846094c7593e27453e62855e61181089c48cf"