summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-08-22 08:29:04 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-22 17:36:13 +0100
commit7ef7923bd9161d562298ace68491a2230210c3e4 (patch)
tree9f89a675ab4871b0198361d746c52eb9794077f3 /meta/recipes-devtools
parent8c5dc072b24c1b82b9254a80efde91aff8e8fa76 (diff)
downloadopenembedded-core-contrib-7ef7923bd9161d562298ace68491a2230210c3e4.tar.gz
quilt: Export QUILT_PC variable in ptest Makefile
The quilt ptest uses a custom Makefile to implement the "make check" rule, but the ptest Makefile does not export the variable QUILT_PC, which is user-settable and normally defaults to ".pc". This causes failures e.g. import.test with "rm -rf patches/ %{QUILT_PC}/", evaluating to "rm -rf patches/ /" if the variable is not set by the Makefile. These ptests broke in: 73d6034f6b quilt: update to 0.66 when the upstream quilt developers enabled users to specify their own QUILT_PC string. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/quilt/quilt/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/quilt/quilt/Makefile b/meta/recipes-devtools/quilt/quilt/Makefile
index 7b3ac8a492..1f6cd2479c 100644
--- a/meta/recipes-devtools/quilt/quilt/Makefile
+++ b/meta/recipes-devtools/quilt/quilt/Makefile
@@ -2,7 +2,8 @@ PATH := $(CURDIR)/bin:$(CURDIR)/compat:$(PATH)
QUILT_DIR := $(CURDIR)/quilt
QUILTRC := $(CURDIR)/test/test.quiltrc
export QUILT_DIR QUILTRC
-CHECK_ENV := P=patches/; _P=../patches/; export P _P
+CHECK_ENV := P=patches/; _P=../patches/; export P _P;
+CHECK_ENV += QUILT_PC=.pc; export QUILT_PC
-include test/.depend
check-% : test/%.test