aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-16 14:10:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-17 00:22:52 +0100
commitf6ed82482838e34202721be8f40ca1cc340c325e (patch)
treeb21059d0b60f1d1547ceaa583c5931c1e6adf5c9 /meta/recipes-devtools
parent586875cea5769fea7d17bae2677eab72e4fc7e31 (diff)
downloadopenembedded-core-contrib-f6ed82482838e34202721be8f40ca1cc340c325e.tar.gz
mkelfimage: Make -fno-stack-protector effective
mkelfimage uses different flags to compile as freestanding binary it does not pour CFLAGS into them during configure as a result -fno-stack-protector was never used. Which failed to build with compilers configured to build with ssp by default. It worked with gcc since we do not configure our toolchain to default to ssp Fixes errors e.g. | objdir/linux-i386/convert_params.o: In function `convert_params': | linux-i386/convert_params.c:(.text+0x9f4): undefined reference to `__stack_chk_fail' | objdir/linux-i386/convert_params.o: In function `compute_checksum': | linux-i386/convert_params.c:(.text+0xa71): undefined reference to `__stack_chk_fail' | objdir/linux-i386/convert_params.o: In function `printf': | linux-i386/convert_params.c:(.text+0xcc7): undefined reference to `__stack_chk_fail' | make: *** [linux-i386/Makefile:24: objdir/linux-i386/convert] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index 2ad4b49ab1..05a5a1a489 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -23,11 +23,12 @@ CLEANBROKEN = "1"
S = "${WORKDIR}/git/util/mkelfImage"
-CFLAGS += "-fno-stack-protector"
CACHED_CONFIGUREVARS += "\
HOST_CC='${BUILD_CC}' \
HOST_CFLAGS='${BUILD_CFLAGS}' \
HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
+ I386_CFLAGS='-fno-stack-protector' \
+ IA64_CFLAGS='-fno-stack-protector' \
"
EXTRA_OECONF_append_x86-64 = " --with-i386=${HOST_SYS}"