summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2019-11-19 15:11:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-29 17:37:17 +0000
commit95c6a1180f14e1db815ff92f7a1dce8506bdb294 (patch)
tree17fe668ecab61df30293d93fcb4532209473c012 /meta/recipes-devtools
parentf6164cc210d584efb702445dcd2167aa352b40af (diff)
downloadopenembedded-core-contrib-95c6a1180f14e1db815ff92f7a1dce8506bdb294.tar.gz
python3: add python3-misc-native to RPROVIDES
The package python3-misc is not in the manifest file so it needs to be added explicitely to RPROVIDES_class-native. Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.5.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.5.bb b/meta/recipes-devtools/python/python3_3.7.5.bb
index 90914f9053..57eaaea5e7 100644
--- a/meta/recipes-devtools/python/python3_3.7.5.bb
+++ b/meta/recipes-devtools/python/python3_3.7.5.bb
@@ -226,6 +226,9 @@ python(){
pn = 'python3'
rprovides = d.getVar('RPROVIDES').split()
+ # ${PN}-misc-native is not in the manifest
+ rprovides.append(pn + '-misc-native')
+
for key in python_manifest:
pypackage = pn + '-' + key + '-native'
if pypackage not in rprovides: