summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-26 10:45:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-29 17:37:17 +0000
commit260804462766116941a1d9100ef8be3e66b93300 (patch)
treeacfef2f8938326f4a5d7c06ac0bcee488c30dfea /meta/recipes-devtools
parentf49077af44969212530a7f1b5cb9370fefb85434 (diff)
downloadopenembedded-core-contrib-260804462766116941a1d9100ef8be3e66b93300.tar.gz
python: use correct autotools variables
Use EXTRA_OECONF and CACHED_CONFIGUREVARS as nature intended. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.17.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.17.bb b/meta/recipes-devtools/python/python_2.7.17.bb
index 5807f63db4..b3bdcba1a8 100644
--- a/meta/recipes-devtools/python/python_2.7.17.bb
+++ b/meta/recipes-devtools/python/python_2.7.17.bb
@@ -36,9 +36,11 @@ S = "${WORKDIR}/Python-${PV}"
inherit autotools multilib_header python-dir pythonnative ptest
-CONFIGUREOPTS += " --with-system-ffi "
+EXTRA_OECONF += "--with-system-ffi"
-EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no ac_cv_working_tzset=yes"
+CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes \
+ ac_cv_file__dev_ptc=no \
+ ac_cv_working_tzset=yes"
PACKAGECONFIG ??= "bdb"
PACKAGECONFIG[bdb] = ",,db"