summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-26 10:28:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-29 17:37:17 +0000
commit1e0ef76dcccfa10cdf473670acd2c52332bb3412 (patch)
treee2211abdac158b779b461999ff2b8d6e972f7e76 /meta/recipes-devtools
parentc4ae09134732e4e95f17d6e572756bec49a9e3d0 (diff)
downloadopenembedded-core-contrib-1e0ef76dcccfa10cdf473670acd2c52332bb3412.tar.gz
python: package .pyo files too
The manifest parsing code was only adding .py and .pyc paths to FILES, generalise the latter to .py? so it catches .pyo files too. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.17.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.17.bb b/meta/recipes-devtools/python/python_2.7.17.bb
index ef5d564481..5807f63db4 100644
--- a/meta/recipes-devtools/python/python_2.7.17.bb
+++ b/meta/recipes-devtools/python/python_2.7.17.bb
@@ -218,7 +218,7 @@ python(){
d.appendVar('FILES_' + pypackage, ' ' + value)
if include_pycs == '1':
if value.endswith('.py'):
- d.appendVar('FILES_' + pypackage, ' ' + value + 'c')
+ d.appendVar('FILES_' + pypackage, ' ' + value + '?')
for value in python_manifest[key]['rdepends']:
# Make it work with or without $PN