aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-12-12 10:31:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 11:21:57 +0000
commitf3d8bda91ee186dae8847d6438c1dfd6f6d8ee4f (patch)
tree2f69d7a0123be62d1caa0aaa563def137da6954a /meta/recipes-devtools
parent18947cd4782934e9bc3ec5507db8db51258d9b2c (diff)
downloadopenembedded-core-contrib-f3d8bda91ee186dae8847d6438c1dfd6f6d8ee4f.tar.gz
ccache-native: Remove dependencies
Remove ccache-native's dependencies so that all native recipes can depend on ccache-native and use it except ccache-native itself. It has the following 4 dependencies: - xz-native: It is intruduced by ccache-3.4.2.tar.xz, use ccache-3.4.2.tar.gz to replace of it can fix the problem. - zlib-native: Use --with-bundled-zlib to fix it. - autotools-native: Set INHIBIT_AUTOTOOLS_DEPS and add a do_configure() to fix the problem. - quilt-native: Set PATCHTOOL = "patch" to fix it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/ccache/ccache.inc13
-rw-r--r--meta/recipes-devtools/ccache/ccache_3.4.2.bb4
2 files changed, 14 insertions, 3 deletions
diff --git a/meta/recipes-devtools/ccache/ccache.inc b/meta/recipes-devtools/ccache/ccache.inc
index 656632893b..7f800659a3 100644
--- a/meta/recipes-devtools/ccache/ccache.inc
+++ b/meta/recipes-devtools/ccache/ccache.inc
@@ -9,8 +9,19 @@ LICENSE = "GPLv3+"
DEPENDS = "zlib"
-SRC_URI = "https://download.samba.org/pub/${BPN}/${BP}.tar.xz"
+SRC_URI = "https://download.samba.org/pub/${BPN}/${BP}.tar.gz"
inherit autotools
+# Remove ccache-native's dependencies, so that it can be used widely by
+# other native recipes.
+DEPENDS_class-native = ""
+EXTRA_OECONF_class-native = "--with-bundled-zlib"
+INHIBIT_AUTOTOOLS_DEPS_class-native = "1"
+PATCHTOOL = "patch"
+
BBCLASSEXTEND = "native"
+
+do_configure_class-native() {
+ oe_runconf
+}
diff --git a/meta/recipes-devtools/ccache/ccache_3.4.2.bb b/meta/recipes-devtools/ccache/ccache_3.4.2.bb
index 72309348b2..921dc3bdff 100644
--- a/meta/recipes-devtools/ccache/ccache_3.4.2.bb
+++ b/meta/recipes-devtools/ccache/ccache_3.4.2.bb
@@ -3,8 +3,8 @@ require ccache.inc
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=2722abeaf1750dbf175b9491112374e1"
-SRC_URI[md5sum] = "9e048f88f3897125864f9a5e1abfb72d"
-SRC_URI[sha256sum] = "18a8b14367d63d3d37fb6c33cba60e1b7fcd7a63d608df97c9771ae0d234fee2"
+SRC_URI[md5sum] = "07d4324efbb3c216bbd1c512f4553480"
+SRC_URI[sha256sum] = "b2264923c63e2b90a17cf56acb1df3f4229c416fb88e476e5ec7e02919d319c3"
SRC_URI += " \
file://0002-dev.mk.in-fix-file-name-too-long.patch \