summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-12-09 13:43:22 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-13 16:32:14 +0000
commit236e801df6e3bd859acc2b8456880a4bc4f0943c (patch)
treed9d8e3a3c9e3f84e61d2737ec6d694c9929d303a /meta/recipes-devtools
parenta1c1253b44eb2000de55b7fa3836e5cdaa28a508 (diff)
downloadopenembedded-core-contrib-236e801df6e3bd859acc2b8456880a4bc4f0943c.tar.gz
liberror-perl: upgrade 0.17026 -> 0.17027
* add RDEPENDS * add RDEPENDS for ptest - tested on qemux86 with glibc and musl * drop do_compile, not obvious why LIBC needed to be set * Added HOMEPAGE: https://bitbucket.org/shlomif/perl-error.pm - Repository used to be github.com/shlomif (deadlink) Upstream release notes: """ 0.17027 2018-10-28 - Documentation and examples enhancements. - https://bitbucket.org/shlomif/perl-error.pm/pull-requests/1/october-prc-some-minor-mostly-doc-changes/diff - Thanks to https://metacpan.org/author/JMERELO . """ Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17027.bb (renamed from meta/recipes-devtools/perl/liberror-perl_0.17026.bb)30
1 files changed, 22 insertions, 8 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17026.bb b/meta/recipes-devtools/perl/liberror-perl_0.17027.bb
index 6f42b47298..cf1f6d685f 100644
--- a/meta/recipes-devtools/perl/liberror-perl_0.17026.bb
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17027.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "The Error package provides two interfaces. Firstly \
Error provides a procedural interface to exception handling. \
Secondly Error is a base class for errors/exceptions that can \
either be thrown, for subsequent catch, or can simply be recorded."
-
+HOMEPAGE = "https://bitbucket.org/shlomif/perl-error.pm"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
@@ -11,20 +11,34 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
DEPENDS += "perl"
+RDEPENDS_${PN} += " \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-scalar-util \
+ perl-module-overload \
+ perl-module-strict \
+ perl-module-vars \
+ perl-module-warnings \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ perl-module-base \
+ perl-module-file-spec \
+ perl-module-io-handle \
+ perl-module-ipc-open3 \
+ perl-module-lib \
+ perl-module-test-more \
+"
+
SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
-SRC_URI[md5sum] = "0dcd94640f617df02b6d6c1e4e92018c"
-SRC_URI[sha256sum] = "37590a962cd73ae03470e1ff16459a6cbc5273fc57626b8981dab9c2433155d9"
+SRC_URI[md5sum] = "4ef9b2890fb144d804527ba32573dd56"
+SRC_URI[sha256sum] = "07b2ac8275dfa04144745a6c1900a596280f862b97d22bab0c5ce02682ebd3be"
S = "${WORKDIR}/Error-${PV}"
inherit cpan ptest-perl
-do_compile() {
- export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
- cpan_do_compile
-}
-
do_install_prepend() {
# test requires "-T" (taint) command line option
rm -rf ${B}/t/pod-coverage.t