aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 17:11:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 13:59:45 +0000
commit38993c3fac841e8e6a01cca43d0d4cecda05439e (patch)
tree0c30bc4b8d336bbda9c24581918ca9644d078bb4 /meta/recipes-devtools
parent351e741cea4538cfe30640bd6e451c0fbc1d0329 (diff)
downloadopenembedded-core-contrib-38993c3fac841e8e6a01cca43d0d4cecda05439e.tar.gz
python-six: use pypi.bbclass
* Simplify python3-six by using pypi.bbclass - Use PYTHON_PN in .inc to avoid duplication in RDEPENDS Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-six.inc8
-rw-r--r--meta/recipes-devtools/python/python3-six_1.11.0.bb2
2 files changed, 3 insertions, 7 deletions
diff --git a/meta/recipes-devtools/python/python-six.inc b/meta/recipes-devtools/python/python-six.inc
index f9e7d6429d..c77498457d 100644
--- a/meta/recipes-devtools/python/python-six.inc
+++ b/meta/recipes-devtools/python/python-six.inc
@@ -4,13 +4,11 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=35cec5bf04dd0820d0a18533ea7c774a"
-SRC_URI = "https://files.pythonhosted.org/packages/source/s/six/six-${PV}.tar.gz"
SRC_URI[md5sum] = "d12789f9baf7e9fb2524c0c64f1773f8"
SRC_URI[sha256sum] = "70e8a77beed4562e7f14fe23a786b54f6296e34344c23bc42f07b15018ff98e9"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/six/"
-UPSTREAM_CHECK_REGEX = "/six/(?P<pver>(\d+[\.\-_]*)+)"
+inherit pypi
-BBCLASSEXTEND = "native nativesdk"
+RDEPENDS_${PN} = "${PYTHON_PN}-io"
-S = "${WORKDIR}/six-${PV}"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-six_1.11.0.bb b/meta/recipes-devtools/python/python3-six_1.11.0.bb
index 38a47b77dd..8795313bec 100644
--- a/meta/recipes-devtools/python/python3-six_1.11.0.bb
+++ b/meta/recipes-devtools/python/python3-six_1.11.0.bb
@@ -1,4 +1,2 @@
inherit setuptools3
require python-six.inc
-
-RDEPENDS_${PN} += "python3-io"