summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-08 14:24:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-13 15:18:28 +0000
commit5a1a322cfca2a514707eeb48f4c3dce5e4c1ad48 (patch)
treef488af70d9fa3cf00060ea32345b2777be358638 /meta/recipes-devtools
parent02c5f853f30568eb3f289c6b6fb5cacf712d15f7 (diff)
downloadopenembedded-core-contrib-5a1a322cfca2a514707eeb48f4c3dce5e4c1ad48.tar.gz
distcc: Handle upstream branch deletion for old releases
distcc upstream dropped the 3.2 branch which we reference in older project releases the revisions are there, just the branch is not. In order to be able to continue to build those old releases, adjust any mirror tarball to contain the missing branch. We have updated the newer point releases but the previous tags were failing to build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.3.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.3.2.bb b/meta/recipes-devtools/distcc/distcc_3.3.2.bb
index 0d06963165..a93604bc47 100644
--- a/meta/recipes-devtools/distcc/distcc_3.3.2.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.3.2.bb
@@ -69,3 +69,27 @@ FILES_${PN} = " ${sysconfdir} \
${systemd_unitdir}/system/distcc.service"
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
${datadir}/distcc"
+
+
+#
+# distcc upstream dropped the 3.2 branch which we reference in older project releases
+# the revisions are there, just the branch is not. In order to be able to continue
+# to build those old releases, adjust any mirror tarball to contain the missing branch
+#
+fixup_distcc_mirror_tarball () {
+ TBALL=${DL_DIR}/git2_github.com.distcc.distcc.git.tar.gz
+ if [ -f $TBALL ]; then
+ TDIR=`mktemp -d`
+ cd $TDIR
+ tar -xzf $TBALL
+ set +e
+ git rev-parse --verify 3.2
+ if [ "$?" != "0" ]; then
+ git branch 3.2 d8b18df3e9dcbe4f092bed565835d3975e99432c
+ tar -czf $TBALL *
+ fi
+ set -e
+ rm -rf $TDIR/*
+ fi
+}
+do_fetch[postfuncs] += "fixup_distcc_mirror_tarball"