aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2018-12-14 19:54:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-15 17:10:44 +0000
commita0ebc77ee0b461fc30e704f7dd9e9c2061ef4193 (patch)
treea83af14e3f62f6eca38f091695030432fd7f282b /meta/recipes-devtools
parentc1c881ef7f4faf94f385ae742030382122ee5816 (diff)
downloadopenembedded-core-contrib-a0ebc77ee0b461fc30e704f7dd9e9c2061ef4193.tar.gz
qemuwrapper: Explicitly exit in case of no qemu supported for target
Running qemu for userspace code on unsupported target binaries might be bad idea because qemu could say running in endless loop instead of crashing due to illegal instruction or unsupported binary format. While this is qemu bug we should avoid hitting it by explicitly exiting from the wrapper when qemu backfill considered for machine. Behaviour was observed in do_rootfs stage when building on IBM Power 8 host for PowerPC e7400 target. Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
index 4aada5232d..06f15617df 100644
--- a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
@@ -21,7 +21,8 @@ do_install () {
set -x
if [ ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d)} = False ]; then
- echo "qemuwrapper: qemu usermode is not supported"
+ echo "qemuwrapper: qemu usermode is not supported"
+ exit 1
fi