summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:24:20 +0100
commitc5774fca09de12b29b1f9062e41c71db6abc972b (patch)
tree5f27179733cc83b9b4db69b21957e8f8b64020c6 /meta/recipes-devtools
parent000577afd815fa8399c595d1aef81f4327204327 (diff)
downloadopenembedded-core-contrib-c5774fca09de12b29b1f9062e41c71db6abc972b.tar.gz
python3-numpy: update 1.18.5 -> 1.19.0
License-Update: copyright years Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch11
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-convert-shebang-from-python-to-python3.patch555
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy.inc7
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.19.0.bb (renamed from meta/recipes-devtools/python-numpy/python3-numpy_1.18.5.bb)0
4 files changed, 10 insertions, 563 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch b/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
index 98a9705831..cdb6a473d2 100644
--- a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
+++ b/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
@@ -1,4 +1,4 @@
-From 672a75c8417ce08db9e31fc415ec445479231d5a Mon Sep 17 00:00:00 2001
+From 27f6687e49bf555fc494d2f14bae6ecd0fa30f14 Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Thu, 10 Dec 2015 13:20:30 +0200
Subject: [PATCH] Don't search /usr and so on for libraries by default to
@@ -14,11 +14,11 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
1 file changed, 5 insertions(+), 37 deletions(-)
diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
-index ba2b1f4..f94dce1 100644
+index 3a6a7b2..6c2c3da 100644
--- a/numpy/distutils/system_info.py
+++ b/numpy/distutils/system_info.py
-@@ -278,45 +278,13 @@ if sys.platform == 'win32':
- add_system_root(os.path.join(conda_dir, 'Library'))
+@@ -309,45 +309,13 @@ if sys.platform == 'win32':
+ add_system_root(os.path.join(conda_dir, 'Library'))
else:
- default_lib_dirs = libpaths(['/usr/local/lib', '/opt/lib', '/usr/lib',
@@ -68,3 +68,6 @@ index ba2b1f4..f94dce1 100644
if os.path.join(sys.prefix, 'lib') not in default_lib_dirs:
default_lib_dirs.insert(0, os.path.join(sys.prefix, 'lib'))
+--
+2.17.1
+
diff --git a/meta/recipes-devtools/python-numpy/files/0001-convert-shebang-from-python-to-python3.patch b/meta/recipes-devtools/python-numpy/files/0001-convert-shebang-from-python-to-python3.patch
deleted file mode 100644
index a416244420..0000000000
--- a/meta/recipes-devtools/python-numpy/files/0001-convert-shebang-from-python-to-python3.patch
+++ /dev/null
@@ -1,555 +0,0 @@
-From 00848d760fa3999e2bed759b585452b35d65d6ec Mon Sep 17 00:00:00 2001
-From: Changqing Li <changqing.li@windriver.com>
-Date: Thu, 5 Mar 2020 12:02:35 +0800
-Subject: [PATCH] convert shebang from python to python3
-
-Upstream-Status: Backport
-[https://github.com/numpy/numpy/commit/583901a074dc65145d3d6136ba7dcd02634d680b]
-
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
-
----
- doc/DISTUTILS.rst.txt | 2 +-
- doc/cdoc/numpyfilter.py | 2 +-
- doc/postprocess.py | 2 +-
- doc/summarize.py | 2 +-
- numpy/distutils/conv_template.py | 2 +-
- numpy/distutils/cpuinfo.py | 2 +-
- numpy/distutils/from_template.py | 2 +-
- numpy/distutils/setup.py | 2 +-
- numpy/distutils/system_info.py | 2 +-
- numpy/f2py/__init__.py | 2 +-
- numpy/f2py/auxfuncs.py | 2 +-
- numpy/f2py/capi_maps.py | 2 +-
- numpy/f2py/cb_rules.py | 2 +-
- numpy/f2py/cfuncs.py | 2 +-
- numpy/f2py/common_rules.py | 2 +-
- numpy/f2py/crackfortran.py | 2 +-
- numpy/f2py/diagnose.py | 2 +-
- numpy/f2py/f2py2e.py | 2 +-
- numpy/f2py/f90mod_rules.py | 2 +-
- numpy/f2py/func2subr.py | 2 +-
- numpy/f2py/rules.py | 2 +-
- numpy/f2py/setup.py | 2 +-
- numpy/f2py/use_rules.py | 2 +-
- numpy/linalg/lapack_lite/clapack_scrub.py | 2 +-
- numpy/linalg/lapack_lite/make_lite.py | 2 +-
- numpy/ma/bench.py | 2 +-
- numpy/ma/setup.py | 2 +-
- numpy/matrixlib/setup.py | 2 +-
- numpy/random/_examples/cython/extending.pyx | 2 +-
- numpy/random/_examples/cython/extending_distributions.pyx | 2 +-
- numpy/setup.py | 2 +-
- numpy/testing/print_coercion_tables.py | 2 +-
- numpy/testing/setup.py | 2 +-
- runtests.py | 2 +-
- setup.py | 2 +-
- tools/c_coverage/c_coverage_report.py | 2 +-
- tools/changelog.py | 2 +-
- tools/ci/push_docs_to_repo.py | 2 +-
- tools/find_deprecated_escaped_characters.py | 2 +-
- tools/refguide_check.py | 2 +-
- tools/swig/test/setup.py | 2 +-
- tools/swig/test/testArray.py | 2 +-
- tools/swig/test/testFarray.py | 2 +-
- tools/swig/test/testFlat.py | 2 +-
- tools/swig/test/testFortran.py | 2 +-
- tools/swig/test/testMatrix.py | 2 +-
- tools/swig/test/testSuperTensor.py | 2 +-
- tools/swig/test/testTensor.py | 2 +-
- tools/swig/test/testVector.py | 2 +-
- 49 files changed, 49 insertions(+), 49 deletions(-)
-
-diff --git a/doc/DISTUTILS.rst.txt b/doc/DISTUTILS.rst.txt
-index bcef825..bc1700f 100644
---- a/doc/DISTUTILS.rst.txt
-+++ b/doc/DISTUTILS.rst.txt
-@@ -59,7 +59,7 @@ SciPy pure Python package example
-
- Below is an example of a minimal ``setup.py`` file for a pure SciPy package::
-
-- #!/usr/bin/env python
-+ #!/usr/bin/env python3
- def configuration(parent_package='',top_path=None):
- from numpy.distutils.misc_util import Configuration
- config = Configuration('mypackage',parent_package,top_path)
-diff --git a/doc/cdoc/numpyfilter.py b/doc/cdoc/numpyfilter.py
-index 0ec5069..067bd36 100755
---- a/doc/cdoc/numpyfilter.py
-+++ b/doc/cdoc/numpyfilter.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- numpyfilter.py INPUTFILE
-
-diff --git a/doc/postprocess.py b/doc/postprocess.py
-index 2e50c11..1be6f39 100755
---- a/doc/postprocess.py
-+++ b/doc/postprocess.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- %prog MODE FILES...
-
-diff --git a/doc/summarize.py b/doc/summarize.py
-index cfce271..563af02 100755
---- a/doc/summarize.py
-+++ b/doc/summarize.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- summarize.py
-
-diff --git a/numpy/distutils/conv_template.py b/numpy/distutils/conv_template.py
-index 3bcb7b8..88432c8 100644
---- a/numpy/distutils/conv_template.py
-+++ b/numpy/distutils/conv_template.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- takes templated file .xxx.src and produces .xxx file where .xxx is
- .i or .c or .h, using the following template rules
-diff --git a/numpy/distutils/cpuinfo.py b/numpy/distutils/cpuinfo.py
-index bc97283..87502a9 100644
---- a/numpy/distutils/cpuinfo.py
-+++ b/numpy/distutils/cpuinfo.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- cpuinfo
-
-diff --git a/numpy/distutils/from_template.py b/numpy/distutils/from_template.py
-index c5c1163..af75971 100644
---- a/numpy/distutils/from_template.py
-+++ b/numpy/distutils/from_template.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- process_file(filename)
-diff --git a/numpy/distutils/setup.py b/numpy/distutils/setup.py
-index 82a53bd..646921b 100644
---- a/numpy/distutils/setup.py
-+++ b/numpy/distutils/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
- def configuration(parent_package='',top_path=None):
-diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
-index 4f340b6..189081d 100644
---- a/numpy/distutils/system_info.py
-+++ b/numpy/distutils/system_info.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- This file defines a set of system_info classes for getting
- information about various resources (libraries, library directories,
-diff --git a/numpy/f2py/__init__.py b/numpy/f2py/__init__.py
-index 42e3632..09a3657 100644
---- a/numpy/f2py/__init__.py
-+++ b/numpy/f2py/__init__.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Fortran to Python Interface Generator.
-
- """
-diff --git a/numpy/f2py/auxfuncs.py b/numpy/f2py/auxfuncs.py
-index 404bdbd..d23d959 100644
---- a/numpy/f2py/auxfuncs.py
-+++ b/numpy/f2py/auxfuncs.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Auxiliary functions for f2py2e.
-diff --git a/numpy/f2py/capi_maps.py b/numpy/f2py/capi_maps.py
-index ce79f68..e5d3fd2 100644
---- a/numpy/f2py/capi_maps.py
-+++ b/numpy/f2py/capi_maps.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Copyright 1999,2000 Pearu Peterson all rights reserved,
-diff --git a/numpy/f2py/cb_rules.py b/numpy/f2py/cb_rules.py
-index 183d7c2..93e93fe 100644
---- a/numpy/f2py/cb_rules.py
-+++ b/numpy/f2py/cb_rules.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Build call-back mechanism for f2py2e.
-diff --git a/numpy/f2py/cfuncs.py b/numpy/f2py/cfuncs.py
-index ccb7b3a..cdb783d 100644
---- a/numpy/f2py/cfuncs.py
-+++ b/numpy/f2py/cfuncs.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- C declarations, CPP macros, and C functions for f2py2e.
-diff --git a/numpy/f2py/common_rules.py b/numpy/f2py/common_rules.py
-index f61d881..fe510bf 100644
---- a/numpy/f2py/common_rules.py
-+++ b/numpy/f2py/common_rules.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Build common block mechanism for f2py2e.
-diff --git a/numpy/f2py/crackfortran.py b/numpy/f2py/crackfortran.py
-index 2aaf5d7..fb5ef2f 100755
---- a/numpy/f2py/crackfortran.py
-+++ b/numpy/f2py/crackfortran.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- crackfortran --- read fortran (77,90) code and extract declaration information.
-
-diff --git a/numpy/f2py/diagnose.py b/numpy/f2py/diagnose.py
-index 0241fed..6c0304c 100644
---- a/numpy/f2py/diagnose.py
-+++ b/numpy/f2py/diagnose.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- import os
-diff --git a/numpy/f2py/f2py2e.py b/numpy/f2py/f2py2e.py
-index d03eff9..c17bfd9 100755
---- a/numpy/f2py/f2py2e.py
-+++ b/numpy/f2py/f2py2e.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- f2py2e - Fortran to Python C/API generator. 2nd Edition.
-diff --git a/numpy/f2py/f90mod_rules.py b/numpy/f2py/f90mod_rules.py
-index 85eae80..70be128 100644
---- a/numpy/f2py/f90mod_rules.py
-+++ b/numpy/f2py/f90mod_rules.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Build F90 module support for f2py2e.
-diff --git a/numpy/f2py/func2subr.py b/numpy/f2py/func2subr.py
-index 6010d5a..fdea0c2 100644
---- a/numpy/f2py/func2subr.py
-+++ b/numpy/f2py/func2subr.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Rules for building C/API module with f2py2e.
-diff --git a/numpy/f2py/rules.py b/numpy/f2py/rules.py
-index f2f713b..f87b03c 100755
---- a/numpy/f2py/rules.py
-+++ b/numpy/f2py/rules.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Rules for building C/API module with f2py2e.
-diff --git a/numpy/f2py/setup.py b/numpy/f2py/setup.py
-index a8c1401..2e7a517 100644
---- a/numpy/f2py/setup.py
-+++ b/numpy/f2py/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- setup.py for installing F2PY
-
-diff --git a/numpy/f2py/use_rules.py b/numpy/f2py/use_rules.py
-index 6f44f16..8214f42 100644
---- a/numpy/f2py/use_rules.py
-+++ b/numpy/f2py/use_rules.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
-
- Build 'use others module data' mechanism for f2py2e.
-diff --git a/numpy/linalg/lapack_lite/clapack_scrub.py b/numpy/linalg/lapack_lite/clapack_scrub.py
-index 4345861..91e66e7 100644
---- a/numpy/linalg/lapack_lite/clapack_scrub.py
-+++ b/numpy/linalg/lapack_lite/clapack_scrub.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- import sys, os
-diff --git a/numpy/linalg/lapack_lite/make_lite.py b/numpy/linalg/lapack_lite/make_lite.py
-index 61102d6..0211f4e 100755
---- a/numpy/linalg/lapack_lite/make_lite.py
-+++ b/numpy/linalg/lapack_lite/make_lite.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- Usage: make_lite.py <wrapped_routines_file> <lapack_dir> <output_dir>
-
-diff --git a/numpy/ma/bench.py b/numpy/ma/bench.py
-index a9ba42d..a377436 100644
---- a/numpy/ma/bench.py
-+++ b/numpy/ma/bench.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- # -*- coding: utf-8 -*-
-
- from __future__ import division, print_function
-diff --git a/numpy/ma/setup.py b/numpy/ma/setup.py
-index d1d6c89..a04b79b 100644
---- a/numpy/ma/setup.py
-+++ b/numpy/ma/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
- def configuration(parent_package='',top_path=None):
-diff --git a/numpy/matrixlib/setup.py b/numpy/matrixlib/setup.py
-index d0981d6..57534d1 100644
---- a/numpy/matrixlib/setup.py
-+++ b/numpy/matrixlib/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
- def configuration(parent_package='', top_path=None):
-diff --git a/numpy/random/_examples/cython/extending.pyx b/numpy/random/_examples/cython/extending.pyx
-index 7a0dfe0..3a7f81a 100644
---- a/numpy/random/_examples/cython/extending.pyx
-+++ b/numpy/random/_examples/cython/extending.pyx
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- #cython: language_level=3
-
- from libc.stdint cimport uint32_t
-diff --git a/numpy/random/_examples/cython/extending_distributions.pyx b/numpy/random/_examples/cython/extending_distributions.pyx
-index 1bef506..4da6a4b 100644
---- a/numpy/random/_examples/cython/extending_distributions.pyx
-+++ b/numpy/random/_examples/cython/extending_distributions.pyx
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- #cython: language_level=3
- """
- This file shows how the to use a BitGenerator to create a distribution.
-diff --git a/numpy/setup.py b/numpy/setup.py
-index 4ccdaee..db06c82 100644
---- a/numpy/setup.py
-+++ b/numpy/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
-
-diff --git a/numpy/testing/print_coercion_tables.py b/numpy/testing/print_coercion_tables.py
-index 72b22ce..1e9a301 100755
---- a/numpy/testing/print_coercion_tables.py
-+++ b/numpy/testing/print_coercion_tables.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Prints type-coercion tables for the built-in NumPy types
-
- """
-diff --git a/numpy/testing/setup.py b/numpy/testing/setup.py
-index 7c3f2fb..bd315ee 100755
---- a/numpy/testing/setup.py
-+++ b/numpy/testing/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
-
-diff --git a/runtests.py b/runtests.py
-index a38054f..383ddaa 100755
---- a/runtests.py
-+++ b/runtests.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- runtests.py [OPTIONS] [-- ARGS]
-
-diff --git a/setup.py b/setup.py
-index d7f807b..705ea5d 100755
---- a/setup.py
-+++ b/setup.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """ NumPy is the fundamental package for array computing with Python.
-
- It provides:
-diff --git a/tools/c_coverage/c_coverage_report.py b/tools/c_coverage/c_coverage_report.py
-index 327f6dc..8837684 100755
---- a/tools/c_coverage/c_coverage_report.py
-+++ b/tools/c_coverage/c_coverage_report.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- A script to create C code-coverage reports based on the output of
- valgrind's callgrind tool.
-diff --git a/tools/changelog.py b/tools/changelog.py
-index b135b14..5d8b33c 100755
---- a/tools/changelog.py
-+++ b/tools/changelog.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- # -*- encoding:utf-8 -*-
- """
- Script to generate contributor and pull request lists
-diff --git a/tools/ci/push_docs_to_repo.py b/tools/ci/push_docs_to_repo.py
-index a989668..ae53054 100755
---- a/tools/ci/push_docs_to_repo.py
-+++ b/tools/ci/push_docs_to_repo.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- import argparse
- import subprocess
-diff --git a/tools/find_deprecated_escaped_characters.py b/tools/find_deprecated_escaped_characters.py
-index 6f90001..10e0378 100644
---- a/tools/find_deprecated_escaped_characters.py
-+++ b/tools/find_deprecated_escaped_characters.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- r"""
- Look for escape sequences deprecated in Python 3.6.
-
-diff --git a/tools/refguide_check.py b/tools/refguide_check.py
-index 2c62809..a19a29e 100644
---- a/tools/refguide_check.py
-+++ b/tools/refguide_check.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- refguide_check.py [OPTIONS] [-- ARGS]
-
-diff --git a/tools/swig/test/setup.py b/tools/swig/test/setup.py
-index 4ff870e..f8f05e6 100755
---- a/tools/swig/test/setup.py
-+++ b/tools/swig/test/setup.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
- # System imports
-diff --git a/tools/swig/test/testArray.py b/tools/swig/test/testArray.py
-index 8d9c797..54ffe71 100755
---- a/tools/swig/test/testArray.py
-+++ b/tools/swig/test/testArray.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testFarray.py b/tools/swig/test/testFarray.py
-index e8bf711..b377f7c 100755
---- a/tools/swig/test/testFarray.py
-+++ b/tools/swig/test/testFarray.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testFlat.py b/tools/swig/test/testFlat.py
-index 71be277..55034bf 100755
---- a/tools/swig/test/testFlat.py
-+++ b/tools/swig/test/testFlat.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testFortran.py b/tools/swig/test/testFortran.py
-index 426e894..0f7d0e6 100644
---- a/tools/swig/test/testFortran.py
-+++ b/tools/swig/test/testFortran.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testMatrix.py b/tools/swig/test/testMatrix.py
-index 065be0d..854a23c 100755
---- a/tools/swig/test/testMatrix.py
-+++ b/tools/swig/test/testMatrix.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testSuperTensor.py b/tools/swig/test/testSuperTensor.py
-index 97fe80c..31b63d0 100644
---- a/tools/swig/test/testSuperTensor.py
-+++ b/tools/swig/test/testSuperTensor.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, print_function
-
- # System imports
-diff --git a/tools/swig/test/testTensor.py b/tools/swig/test/testTensor.py
-index ac1b749..f47d9e8 100755
---- a/tools/swig/test/testTensor.py
-+++ b/tools/swig/test/testTensor.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
-diff --git a/tools/swig/test/testVector.py b/tools/swig/test/testVector.py
-index 45e763b..067b922 100755
---- a/tools/swig/test/testVector.py
-+++ b/tools/swig/test/testVector.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#!/usr/bin/env python3
- from __future__ import division, absolute_import, print_function
-
- # System imports
diff --git a/meta/recipes-devtools/python-numpy/python-numpy.inc b/meta/recipes-devtools/python-numpy/python-numpy.inc
index 75309e3080..e37ab399ed 100644
--- a/meta/recipes-devtools/python-numpy/python-numpy.inc
+++ b/meta/recipes-devtools/python-numpy/python-numpy.inc
@@ -1,15 +1,14 @@
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a32aba007a415aa8a1c708a0e2b86a1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=643d4e90100b7abe468c4db88127b895"
SRCNAME = "numpy"
SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
- file://0001-convert-shebang-from-python-to-python3.patch \
"
-SRC_URI[sha256sum] = "2c095bd1c5290966cceee8b6ef5cd66f13cd0e9d6d0e8d6fc8961abd64a8e51f"
+SRC_URI[sha256sum] = "153cf8b0176e57a611931981acfe093d2f7fef623b48f91176efa199798a6b90"
UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
@@ -20,7 +19,7 @@ S = "${WORKDIR}/numpy-${PV}"
CLEANBROKEN = "1"
-FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
+FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
# install what is needed for numpy.test()
RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.18.5.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.0.bb
index d388e88d25..d388e88d25 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.18.5.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.0.bb