summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:24:20 +0100
commit6f8020c5d50da705fbb077f647a5bb304f2cf710 (patch)
treea0b7e853f54d8ff6dfa0022e053771734da66669 /meta/recipes-devtools
parentdb90ff4005cdf837617a7c5c58ae03d7570b062e (diff)
downloadopenembedded-core-contrib-6f8020c5d50da705fbb077f647a5bb304f2cf710.tar.gz
libdnf: update 0.47.0 -> 0.48.0
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/libdnf/libdnf/0001-Add-WITH_TESTS-option.patch10
-rw-r--r--meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch36
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_0.48.0.bb (renamed from meta/recipes-devtools/libdnf/libdnf_0.47.0.bb)3
3 files changed, 6 insertions, 43 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf/0001-Add-WITH_TESTS-option.patch b/meta/recipes-devtools/libdnf/libdnf/0001-Add-WITH_TESTS-option.patch
index ac9400c48d..384add5e12 100644
--- a/meta/recipes-devtools/libdnf/libdnf/0001-Add-WITH_TESTS-option.patch
+++ b/meta/recipes-devtools/libdnf/libdnf/0001-Add-WITH_TESTS-option.patch
@@ -1,4 +1,4 @@
-From 56fa2bbdbd29377a6ef0d0b7aadbac8b5ea8c95b Mon Sep 17 00:00:00 2001
+From 7d60d62b5c5374156703ca7262fb2f85ec5db119 Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Tue, 6 Nov 2018 13:54:43 +0100
Subject: [PATCH] Add WITH_TESTS option
@@ -14,7 +14,7 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
2 files changed, 5 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 881152a..965c992 100644
+index 9c6e1b2f..8599c540 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,7 @@ option(WITH_MAN "Enables hawkey man page generation" ON)
@@ -24,8 +24,8 @@ index 881152a..965c992 100644
+option(WITH_TESTS "Enables unit tests" ON)
- # load pkg-config first; it's required by other modules
-@@ -165,8 +166,10 @@ endif()
+ # build options - debugging
+@@ -179,8 +180,10 @@ endif()
# build tests
@@ -37,7 +37,7 @@ index 881152a..965c992 100644
add_subdirectory(python/hawkey)
endif()
diff --git a/python/hawkey/CMakeLists.txt b/python/hawkey/CMakeLists.txt
-index d964534..84d1720 100644
+index d9645346..84d17204 100644
--- a/python/hawkey/CMakeLists.txt
+++ b/python/hawkey/CMakeLists.txt
@@ -50,4 +50,6 @@ target_link_libraries(_hawkeymodule ${PYTHON_LIBRARY})
diff --git a/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch b/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch
deleted file mode 100644
index 6be484fea3..0000000000
--- a/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 96ca7d0049461df2293dd0000edcbc69b64255e0 Mon Sep 17 00:00:00 2001
-From: Peter Kjellerstedt <pkj@axis.com>
-Date: Sun, 3 May 2020 22:40:39 +0200
-Subject: [PATCH] Use single-quotes around string literals used in SQL
- statements
-
-If sqlite is built with -DSQLITE_DQS=0 in accordance with
-https://sqlite.org/quirks.html#dblquote, migration to version 1.2 of the
-history database would fail with:
-
- History database cannot be created: /var/lib/dnf/history.sqlite.
- Error: SQLite error on ":memory:": Executing an SQL statement failed:
- no such column: 1.2
-
-Upstream-Status: Submitted [https://github.com/rpm-software-management/libdnf/pull/951]
-Signed-off-by: Peter Kjellerstedt <pkj@axis.com>
----
- libdnf/transaction/sql/migrate_tables_1_2.sql | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libdnf/transaction/sql/migrate_tables_1_2.sql b/libdnf/transaction/sql/migrate_tables_1_2.sql
-index 49b75315..f80ad1c4 100644
---- a/libdnf/transaction/sql/migrate_tables_1_2.sql
-+++ b/libdnf/transaction/sql/migrate_tables_1_2.sql
-@@ -1,9 +1,9 @@
- R"**(
- BEGIN TRANSACTION;
- ALTER TABLE trans
-- ADD comment TEXT DEFAULT "";
-+ ADD comment TEXT DEFAULT '';
- UPDATE config
-- SET value = "1.2"
-+ SET value = '1.2'
- WHERE key = 'version';
- COMMIT;
- )**"
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.48.0.bb
index 1b06d66b19..947b2f2348 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.48.0.bb
@@ -8,10 +8,9 @@ SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
file://0001-Add-WITH_TESTS-option.patch \
file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
- file://0001-Use-single-quotes-around-string-literals-used-in-SQL.patch \
"
-SRCREV = "8330eea6985c4e4b53796f858de5b6b38b1ddf5c"
+SRCREV = "46a28d0cf09277fffc11392e5e362a2eda0d53a8"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
S = "${WORKDIR}/git"