summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-06-05 15:47:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-09 17:12:04 +0100
commiteb441e047498be42af9c8bf69edb1164360a61f1 (patch)
tree05d063dc7a1a0dc9ce8bba0250777f51be53f8fc /meta/recipes-devtools
parent2f6a506018973f0eaf1306555df3e74a3ab25680 (diff)
downloadopenembedded-core-contrib-eb441e047498be42af9c8bf69edb1164360a61f1.tar.gz
mkelfimage: Fix broken patch when building native
A change occured about a year ago that broke the native build, fix that patch [YOCTO #11590] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage/fix-makefile-to-find-libz.patch15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage/fix-makefile-to-find-libz.patch b/meta/recipes-devtools/mkelfimage/mkelfimage/fix-makefile-to-find-libz.patch
index 756a65cd92..be547543dd 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage/fix-makefile-to-find-libz.patch
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage/fix-makefile-to-find-libz.patch
@@ -3,8 +3,11 @@ Let makefile find libz and zlib.h by CFLAGS and LDFLAGS.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Upstream-Status: Pending
---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
diff --git a/configure.ac b/configure.ac
-index d1acc36..6f865b0 100644
+index 0f2ac72..f9099a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,7 +62,7 @@ AC_CHECK_PROG([RPM], rpm, rpm, [], [$PATH])
@@ -16,15 +19,15 @@ index d1acc36..6f865b0 100644
dnl Find the default programs
if test "with_default" != no ; then
-@@ -175,7 +175,7 @@ fi
-
+@@ -176,7 +176,7 @@ fi
dnl ---Output variables...
--HOST_CFLAGS="$HOST_CFLAGS -O2 -Wall \$(HOST_CPPFLAGS)"
-+HOST_CFLAGS="$HOST_CFLAGS -O2 -Wall \$(HOST_CPPFLAGS) $CFLAGS"
+ CFLAGS="${CFLAGS:--O2} -Wall \$(CPPFLAGS)"
+-HOST_CFLAGS="${HOST_CFLAGS:--O2} -Wall \$(HOST_CPPFLAGS)"
++HOST_CFLAGS="${HOST_CFLAGS:--O2} -Wall \$(HOST_CPPFLAGS) $CFLAGS"
dnl TODO: figure out how to set these appropriately for compilers other than gcc
I386_CFLAGS="$I386_CFLAGS -Os -ffreestanding -Wall -W -Wno-format \$(I386_CPPFLAGS)"
--
-1.7.10.4
+2.7.4