summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-06-12 09:25:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-13 10:46:30 +0100
commit61ecda8f7977ee2d30f31d2f384f65f933971568 (patch)
treeb74b747ffd94af84db42e9d4af0b4327f78e4bed /meta/recipes-devtools
parent653299d8c31eac6147b8183d9ec7ef82b7202cab (diff)
downloadopenembedded-core-contrib-61ecda8f7977ee2d30f31d2f384f65f933971568.tar.gz
rpm: add explicit dependency on bzip2-replacement-native for native builds
This fixes a following error: | recipe-sysroot-native/usr/lib/rpm/debugedit: error while loading shared libraries: \ | libbz2.so.1: cannot open shared object file: No such file or directory Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index e721dfba0b..2a0dcafac7 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -50,8 +50,8 @@ SRCREV = "a8e51b3bb05c6acb1d9b2e3d34f859ddda1677be"
S = "${WORKDIR}/git"
-DEPENDS = "nss libarchive db file popt xz dbus elfutils python3"
-DEPENDS_append_class-native = " file-replacement-native"
+DEPENDS = "nss libarchive db file popt xz bzip2 dbus elfutils python3"
+DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
inherit autotools gettext pkgconfig python3native
export PYTHON_ABI