aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-02-05 10:02:34 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-07 17:29:45 +0000
commitc5629268b0f8ae0a425c98337d13e8dc83107e13 (patch)
tree12a23cdc83e02a8769ab1ba14b6b6ec460327094 /meta/recipes-devtools
parent6af50d8865335aed68fb4f9b319edb81ce93a04e (diff)
downloadopenembedded-core-contrib-c5629268b0f8ae0a425c98337d13e8dc83107e13.tar.gz
python: set PYTHONHOME for nativesdk
This ensures that the nativesdk python functions correctly without needing to set PYTHONHOME in the sdk environment setup script. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.11.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.11.bb b/meta/recipes-devtools/python/python_2.7.11.bb
index 0287c191ab..0c00d6e4e4 100644
--- a/meta/recipes-devtools/python/python_2.7.11.bb
+++ b/meta/recipes-devtools/python/python_2.7.11.bb
@@ -123,7 +123,7 @@ do_install() {
}
do_install_append_class-nativesdk () {
- create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
+ create_wrapper ${D}${bindir}/python2.7 PYTHONHOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
}
SSTATE_SCAN_FILES += "Makefile"