summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-20 15:53:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-21 00:33:23 +0100
commitf384e39ad1ca1514fb7b5d7fa0d63e0c863761ca (patch)
tree24fdc4b93f2dee194387c86c7b016b099e89cbf9 /meta/recipes-devtools
parente810484c7292f7fb96dd01ef4b3c2e1ffd384770 (diff)
downloadopenembedded-core-contrib-f384e39ad1ca1514fb7b5d7fa0d63e0c863761ca.tar.gz
python: make 'python' install everything instead of just the interpretter
Follow the python3 behaviour, and common sense, by making 'python' install python-modules instead of python-core. This means a user installing python gets all of Python, instead of just a fraction of the library. [ YOCTO #13402 ] (From OE-Core rev: 778a6b4bf6aa9d0941d52ee05e14b061b659b3df) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.16.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.16.bb b/meta/recipes-devtools/python/python_2.7.16.bb
index d70342fe3a..5f387b8af1 100644
--- a/meta/recipes-devtools/python/python_2.7.16.bb
+++ b/meta/recipes-devtools/python/python_2.7.16.bb
@@ -162,7 +162,7 @@ py_package_preprocess () {
PACKAGES_remove = "${PN}"
# manual dependency additions
-RPROVIDES_${PN}-core = "${PN}"
+RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
RRECOMMENDS_${PN}-crypt = "openssl"