summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-31 17:56:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-01 21:43:30 +0100
commit5c0d4e59d4a12374a3460743d9805c7b75f56d6e (patch)
treef75e24036b295ae73e0ab78397e5bdbfdb30636a /meta/recipes-devtools
parent914c33e8ff77e6bb95ce9a46c9bde7fa2f45c583 (diff)
downloadopenembedded-core-contrib-5c0d4e59d4a12374a3460743d9805c7b75f56d6e.tar.gz
python3-pygments: add a recipe
This is the new source highlighter used by gtk-doc. (From OE-Core rev: 18ac8091728ede09024385cc71acff2b59500017) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-pygments_2.4.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygments_2.4.2.bb b/meta/recipes-devtools/python/python3-pygments_2.4.2.bb
new file mode 100644
index 0000000000..35c0ac6a57
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygments_2.4.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Pygments is a syntax highlighting package written in Python."
+DESCRIPTION = "Pygments is a syntax highlighting package written in Python."
+HOMEPAGE = "http://pygments.org/"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e1d7b7bffbfeaa14083fd2bd3236aea8"
+
+inherit setuptools3
+SRC_URI[md5sum] = "5ecc3fbb2a783e917b369271fc0e6cd1"
+SRC_URI[sha256sum] = "881c4c157e45f30af185c1ffe8d549d48ac9127433f2c380c24b84572ad66297"
+
+DEPENDS += "\
+ ${PYTHON_PN} \
+ "
+
+PYPI_PACKAGE = "Pygments"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
+