summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-26 23:41:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 11:12:12 +0000
commite093eff9d94c02939ca398d59d66d1b1dbc8a12e (patch)
treefc594204e01227b3de0b6a8aa79c7f87c1d8d470 /meta/recipes-devtools
parentf437b226aac498240bc1e3a02eb0257a7deeedea (diff)
downloadopenembedded-core-contrib-e093eff9d94c02939ca398d59d66d1b1dbc8a12e.tar.gz
llvm: Fix build with c++17
Fixes /benchmark_register.h:17:30: error: 'numeric_limits' is not a member of 'std' | static const T kmax = std::numeric_limits<T>::max(); | ^~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/llvm/llvm/0001-nfc-Fix-missing-include.patch26
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm/0001-nfc-Fix-missing-include.patch b/meta/recipes-devtools/llvm/llvm/0001-nfc-Fix-missing-include.patch
new file mode 100644
index 0000000000..f6dee77ab2
--- /dev/null
+++ b/meta/recipes-devtools/llvm/llvm/0001-nfc-Fix-missing-include.patch
@@ -0,0 +1,26 @@
+From 3b7e611bd58ba842470d17374c550e14bceca5c7 Mon Sep 17 00:00:00 2001
+From: serge-sans-paille <sguelton@redhat.com>
+Date: Tue, 10 Nov 2020 14:55:25 +0100
+Subject: [PATCH] [nfc] Fix missing include
+
+Upstream-Status: Backport [https://github.com/llvm/llvm-project/commit/b498303066a63a203d24f739b2d2e0e56dca70d1]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ llvm/utils/benchmark/src/benchmark_register.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/llvm/utils/benchmark/src/benchmark_register.h b/llvm/utils/benchmark/src/benchmark_register.h
+index 0705e219f2fa..4caa5ad4da07 100644
+--- a/llvm/utils/benchmark/src/benchmark_register.h
++++ b/llvm/utils/benchmark/src/benchmark_register.h
+@@ -1,6 +1,7 @@
+ #ifndef BENCHMARK_REGISTER_H
+ #define BENCHMARK_REGISTER_H
+
++#include <limits>
+ #include <vector>
+
+ #include "check.h"
+--
+2.30.1
+
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 86def0878c..db6694339c 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
+ file://0001-nfc-Fix-missing-include.patch;striplevel=2 \
"
UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"