summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@cn.fujitsu.com>2019-04-25 08:03:58 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-26 10:05:23 +0100
commit88843ff56a8ac8addea3eadb73651bbf49d1509d (patch)
treec67c1356d966b7e896c42263ed38c7cf7db4fae6 /meta/recipes-devtools
parent38e2602426945de257a1bd9dd7e70e7b3499a4bf (diff)
downloadopenembedded-core-contrib-88843ff56a8ac8addea3eadb73651bbf49d1509d.tar.gz
dnf: Enable nativesdk
Make dnf work on nativesdk environment. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.2.2.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.2.2.bb b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
index 3970b41121..c77773332c 100644
--- a/meta/recipes-devtools/dnf/dnf_4.2.2.bb
+++ b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
@@ -26,7 +26,7 @@ EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -
BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}_class-target += " \
+RDEPENDS_${PN} += " \
python3-core \
python3-codecs \
python3-netclient \
@@ -49,6 +49,8 @@ RDEPENDS_${PN}_class-target += " \
python3-gpg \
"
+RDEPENDS_${PN}_class-native = ""
+
RRECOMMENDS_${PN}_class-target += "gnupg"
# Create a symlink called 'dnf' as 'make install' does not do it, but
@@ -66,6 +68,12 @@ do_install_append_class-native() {
RPM_NO_CHROOT_FOR_SCRIPTS=1
}
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/dnf \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
+ RPM_NO_CHROOT_FOR_SCRIPTS=1
+}
+
SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
dnf-automatic.service dnf-automatic.timer \
dnf-automatic-download.service dnf-automatic-download.timer \