aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-04-11 00:29:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 22:01:54 +0100
commit2dd22dff121b3effe40abe4370de89231785a823 (patch)
tree7e0cbe344972e53c7c79726325916663dbfa3af0 /meta/recipes-devtools
parent4e9d7fc44a1fcefe15dd66905ae0dbbc7dc1ca9d (diff)
downloadopenembedded-core-contrib-2dd22dff121b3effe40abe4370de89231785a823.tar.gz
python3: fix building nativesdk-python3
When the class nativesdk.bbclass is inherited, it redefines TARGET_CC_ARCH, in the case of python3, this enables debug, causing an error while linking. Since we don't enable debug during configure some functions are not declared. This patch makes sure we keep debug disabled, fixing the linking errors. [YOCTO #9357] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index f61d278d79..4f4e79cfd7 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -61,6 +61,7 @@ CACHED_CONFIGUREVARS = "ac_cv_have_chflags=no \
TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
TARGET_CC_ARCH += "-DNDEBUG -fno-inline"
+SDK_CC_ARCH += "-DNDEBUG -fno-inline"
EXTRA_OEMAKE += "CROSS_COMPILE=yes"
EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ --without-ensurepip"