summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-09 21:21:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-10 14:29:46 +0000
commit4055dd6cc89af16b3723e38b63d4d81efb0e2286 (patch)
tree80774ea0d26a5576f5c211722edd5c2be4ea9a4d /meta/recipes-devtools
parent26ed998c4f201c5cacf330f52e51e416afbd300c (diff)
downloadopenembedded-core-contrib-4055dd6cc89af16b3723e38b63d4d81efb0e2286.tar.gz
python3: correctly adjust include paths in sysconfigdata
This was replacing /usr/include regardless of whether it was at the beginning of the full path (correct, when building target python3), or in the middle of it (not correct, when building native or nativesdk python). Through various reasons we haven't been bitten by this until now, but latest setuptools does expose the problem with for example nativesdk-python3-cffi and nativesdk-python3-cryptography which both fail without this fix. I am not aware of anything using INCLDIRSTOMAKE, and it is harder to adjust correctly due to the value being a list; if something is using it, we can look at it specifically. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3_3.11.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.11.0.bb b/meta/recipes-devtools/python/python3_3.11.0.bb
index 6b6c983abf..92a1f69320 100644
--- a/meta/recipes-devtools/python/python3_3.11.0.bb
+++ b/meta/recipes-devtools/python/python3_3.11.0.bb
@@ -186,8 +186,8 @@ do_install:append() {
-e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
-e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
-e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
- -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
- -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
+ -e "s,^ 'INCLUDEPY'.*, 'INCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
+ -e "s,^ 'CONFINCLUDEPY'.*, 'CONFINCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
-e "s,${B},/build/path/unavailable/,g" \
$sysconfigfile
cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py