summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-11-18 09:52:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-22 12:18:41 +0000
commit285643275ef0ac04bdc3ce500a79f49629e7ebba (patch)
tree2734c4f02d5d24e4e67d33534cf3de387ce49d44 /meta/recipes-devtools
parentc26f9a01f6c94cc65b5811cad31f88e4f432a162 (diff)
downloadopenembedded-core-contrib-285643275ef0ac04bdc3ce500a79f49629e7ebba.tar.gz
libtest-fatal-perl: add recipe for 0.016
Test::Fatal - incredibly simple helpers for testing code with exceptions https://metacpan.org/release/RJBS/Test-Fatal-0.016 * Dependency for liburi-perl ptest. * Add self as maintainer * Add to ptest-packages.inc (fast) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
new file mode 100644
index 0000000000..6d36c94eeb
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Incredibly simple helpers for testing code with exceptions"
+DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\
+It does much less, but should allow greater flexibility in testing \
+exception-throwing code with about the same amount of typing."
+HOMEPAGE = "https://github.com/rjbs/Test-Fatal"
+BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f7c73bf24be1bc7759bde9c15000db6c"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "7283d430f2ba2030b8cd979ae3039d3f1b2ec3dde1a11ca6ae09f992a66f788f"
+
+S = "${WORKDIR}/Test-Fatal-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS:${PN} += "\
+ libtry-tiny-perl \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-test-builder \
+"
+
+RDEPENDS:${PN}-ptest += "\
+ perl-module-extutils-makemaker \
+ perl-module-extutils-mm-unix \
+ perl-module-file-spec \
+ perl-module-overload \
+ perl-module-test-builder-tester \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native nativesdk"