aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-10 11:21:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-10 16:48:31 +0100
commitd196d08acafe599c16a7ac8e04121039b1216ba6 (patch)
tree4712bba8f9307f0eb1230eb567a55aafaa9ca26c /meta/recipes-devtools
parentf9d88a559dd2479893d7570676d42955ee3b8845 (diff)
downloadopenembedded-core-contrib-d196d08acafe599c16a7ac8e04121039b1216ba6.tar.gz
rpm-postinsts: don't create broken postinst script
Not only was the variable reference in this line broken, but it wasn't going to work anyway - we install the script directly into /etc/rcS.d and not into /etc/init.d, so the code in update-rc.d.bbclass couldn't find anything there. This resulted in a postinstall script for rpm-postinsts being created in /etc/rpm-postinsts which can't work when the root filesystem is read-only. To simplify things just remove the use of update-rc.d.bbclass since we don't really need the added complexity here. Fixes [YOCTO #4222]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/rpm/rpm-postinsts.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/recipes-devtools/rpm/rpm-postinsts.bb b/meta/recipes-devtools/rpm/rpm-postinsts.bb
index 27ef2aa384..0a62da0c3c 100644
--- a/meta/recipes-devtools/rpm/rpm-postinsts.bb
+++ b/meta/recipes-devtools/rpm/rpm-postinsts.bb
@@ -5,15 +5,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-2.1;md5=1
RDEPENDS_${PN} = "base-files"
-inherit update-rc.d allarch
+inherit allarch
#
# Allow distributions to alter when [postponed] package install scripts are run
#
POSTINSTALL_INITPOSITION ?= "98"
-INITSCRIPT_NAME = "run-postinsts"
-INITSCRIPT_PARAMS = "start ${{POSTINSTALL_INITPOSITION} S ."
-
POSTLOG ?= "/var/log/postinstall.log"
REDIRECT_CMD = "${@base_contains('IMAGE_FEATURES', 'debug-tweaks', '>>${POSTLOG} 2>&1', '', d)}"