aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-03-22 20:53:51 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-25 10:29:16 +0000
commit7f7c9ab29eba0e58916629ca13dc4a494535ce19 (patch)
tree681f78e89f7daa1492bb04fd8610e32e560e30ee /meta/recipes-devtools
parente33124f828d0cd2dd600fff3f6ad3dc98d2723a1 (diff)
downloadopenembedded-core-contrib-7f7c9ab29eba0e58916629ca13dc4a494535ce19.tar.gz
python-pygobject: use Python 2 instead of Python 3
Ideally this would be an option but that means conditional inherits. For now Python 2 is clearly the default Python in oe-core so switch to Python 2 instead of 3. This stops python3 being pulled inadvertently into builds, and appearing in images that have ptest-pkgs installed (via dbus-test). (From OE-Core rev: 7ae7277a577b2732eff7812860a7c7967644e532) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-pygobject_3.18.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_3.18.2.bb b/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
index e61d75ca3e..8fe1d63423 100644
--- a/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
+++ b/meta/recipes-devtools/python/python-pygobject_3.18.2.bb
@@ -3,9 +3,9 @@ SECTION = "devel/python"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
-inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection
+inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
-DEPENDS += "python3 glib-2.0 gnome-common"
+DEPENDS += "python glib-2.0 gnome-common"
SRCNAME="pygobject"
SRC_URI = " \
@@ -20,6 +20,6 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
BBCLASSEXTEND = "native"
-EXTRA_OECONF = "--disable-cairo"
+EXTRA_OECONF = "--disable-cairo --with-python=python2.7"
-RDEPENDS_${PN} += "python3-setuptools"
+RDEPENDS_${PN} += "python-setuptools"