aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-06 13:20:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-09 23:00:45 +0100
commit50f5ca3c607c3e60bf6d3a431b24d46023310ddb (patch)
treea16e88614b926fc32e82b21510fa4b00f00aa643 /meta/recipes-devtools
parent66ecbd3405b94ff051f9a69936f4387e9a973a86 (diff)
downloadopenembedded-core-contrib-50f5ca3c607c3e60bf6d3a431b24d46023310ddb.tar.gz
rpm: brace expansion is a bashism
The constuct rm *.{a,la} is a bashism and as tasks are run under /bin/sh this may not work as expected. Expand the {a,la} to two separate calls, and remove the architecture-specific macro deletion as they are not installed in the first place anymore. (From OE-Core rev: 0edd06d15d2501ed0961681b56ecbb4ca5e75647) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4+cvs.bb9
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.16.bb9
2 files changed, 8 insertions, 10 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
index bacdef5242..c6c21b86aa 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
@@ -568,16 +568,15 @@ do_install_append() {
rm -f ${D}/${mandir}/man1/lz*.1
rm -f ${D}/${libdir}/pkgconfig/liblzma*
- rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
- rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.a
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.la
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.a
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.la
#find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
# -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
#find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
- # We don't want the default macro set
- rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
-
rm -f ${D}/${libdir}/rpm/dbconvert.sh
rm -f ${D}/${libdir}/rpm/libsqldb.*
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
index 7621f8ffaa..d42724c212 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
@@ -576,16 +576,15 @@ do_install_append() {
rm -f ${D}/${mandir}/man1/lz*.1
rm -f ${D}/${libdir}/pkgconfig/liblzma*
- rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
- rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.a
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.la
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.a
+ rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.la
#find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
# -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
#find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
- # We don't want the default macro set
- rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
-
rm -f ${D}/${libdir}/rpm/dbconvert.sh
rm -f ${D}/${libdir}/rpm/libsqldb.*