aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-12-19 17:50:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-03 14:53:44 +0000
commite8879cd1ec8914815c7a78f1d9b296b0e2b30fcf (patch)
treee6b85350b51ef95d5b68cb583e8f508801e20daf /meta/recipes-devtools
parentab3cc175649dbea6f434bb0f6ee1346f5f0e701a (diff)
downloadopenembedded-core-contrib-e8879cd1ec8914815c7a78f1d9b296b0e2b30fcf.tar.gz
opkg: Merge in opkg-collateral
All non-arch-specific and non-distro-specific configuration is now kept in the main 'opkg' recipe and package. Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb21
-rw-r--r--meta/recipes-devtools/opkg/opkg/opkg.conf (renamed from meta/recipes-devtools/opkg/opkg-collateral/opkg.conf)0
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.2.4.bb14
3 files changed, 13 insertions, 22 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
deleted file mode 100644
index f080dfc3ab..0000000000
--- a/meta/recipes-devtools/opkg/opkg-collateral.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "Constructs the main configuration file for opkg"
-SECTION = "base"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r2"
-
-SRC_URI = "file://opkg.conf"
-
-S = "${WORKDIR}"
-
-OPKGLIBDIR = "${localstatedir}/lib"
-do_compile () {
- echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
-}
-
-do_install () {
- install -d ${D}${sysconfdir}/opkg
- install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"
diff --git a/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf b/meta/recipes-devtools/opkg/opkg/opkg.conf
index c2e9e92f95..c2e9e92f95 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral/opkg.conf
+++ b/meta/recipes-devtools/opkg/opkg/opkg.conf
diff --git a/meta/recipes-devtools/opkg/opkg_0.2.4.bb b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
index be8394a361..5aaabcf08b 100644
--- a/meta/recipes-devtools/opkg/opkg_0.2.4.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
@@ -15,6 +15,7 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz
file://libopkg-opkg_remove.c-avoid-remove-pkg-repeatly-with.patch \
file://remove-ACLOCAL_AMFLAGS-I-shave-I-m4.patch \
file://opkg-configure.service \
+ file://opkg.conf \
"
S = "${WORKDIR}/${BPN}-${PV}"
@@ -51,7 +52,14 @@ do_configure_prepend() {
sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
}
+do_compile_append () {
+ echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
+}
+
do_install_append () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
+
# We need to create the lock directory
install -d ${D}${OPKGLIBDIR}/opkg
@@ -75,7 +83,9 @@ do_install_append () {
RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config run-postinsts"
RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN}_class-nativesdk = ""
-RREPLACES_${PN} = "opkg-nogpg"
+RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
+RCONFLICTS_${PN} = "opkg-collateral"
+RPROVIDES_${PN} = "opkg-collateral"
PACKAGES =+ "libopkg-dev libopkg-staticdev libopkg"
@@ -85,3 +95,5 @@ FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
FILES_${PN} += "${systemd_unitdir}/system/"
BBCLASSEXTEND = "native nativesdk"
+
+CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"