aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-01 16:26:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 17:42:44 +0000
commite36ff98a7a4da478bb886f61005cd72a0b5a9c0e (patch)
tree7fff888856a08e5680895801d829a7df52337787 /meta/recipes-devtools
parentf7b342a73661cfff4043fab77ab8e9ef0e48dec4 (diff)
downloadopenembedded-core-contrib-e36ff98a7a4da478bb886f61005cd72a0b5a9c0e.tar.gz
python: ensure all of Python is installed in nativesdk
If any part of Python gets installed in a SDK, we need to ensure that all of Python gets installed to avoid replacing python in the environment with a minimal package set. [ YOCTO #6735 ] Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 50c751e323..7f13e22f7f 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -161,6 +161,7 @@ require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions
RPROVIDES_${PN}-core = "${PN}"
RRECOMMENDS_${PN}-core = "${PN}-readline"
+RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
RRECOMMENDS_${PN}-crypt = "openssl"
RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"